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Overview and Requirements

Apple Xserve Diagnostics tests your Intel-based Xserve
computer for hardware issues.

Apple Xserve Diagnostics (AXD) runs a customizable set of tests to help you diagnose
issues with the following Xserve components:
+ Boot ROM

« Ethernet controller
- Fan

+ Hard drive

« Memory

« Power supply
 Processor

- Sensor

» USB ports

+ Video controller

You can run AXD in Extensible Firmware Interface (EFI), which is referred to as AXD EFI
tools, or in Mac OS X or Mac OS X Server, which is referred to as AXD Mac OS X tools.

By running AXD EFI tools, you can diagnose hardware issues that prevent Mac OS X
Server from successfully starting up. You can also run tests without interference from
Mac OS X Server and test more than 2.5 gigabytes (GB) of memory. However, AXD
Mac OS X tools provides an enhanced interface and has more extensive sensor, hard
drive, and video controller tests. For a detailed comparison and description of all
available tests, see “AXD Tools Test Reference” on page 35.

You can test the Xserve by running AXD tools directly on the Xserve.You can also run
AXD tools on a computer that has a network connection to the Xserve and test the
Xserve remotely.



Note: This guide describes how to use AXD version 3X104, which is included on the

Admin Tools disc (version 10.5 or later). If you're using a different version of AXD tools,
the instructions in this guide might not work. You can find out which version of AXD
tools you're using by opening AXD Mac OS X tools and choosing AXD > About Apple

Xserve Diagnostics.

Overview of AXD Configurations
You can install and run AXD tools in a variety of ways, so choose the method that best
suits your needs. There are several options, each with advantages and disadvantages:

Option Considerations

Host a NetBoot server

Advantages:

« You can use AXD EFI tools

+ You don't need to install AXD tools on an
internal volume on the Xserve or on a portable
storage device

» You can use a single AXD install image to test
multiple Xserve computers

«+ You can start up AXD tools without an input
device connected to the Xserve (if you have
access to the Xserve front panel)

Disadvantages:

+ You need physical access to the Xserve

- You need a server to host NetBoot service and
the AXD install image

« The Xserve must be on the same subnet as the
NetBoot server

Install AXD EFI tools on an internal volume

Advantages:

« You can use AXD EFI tools

- You don't need a portable storage device

Disadvantages:

- You need physical access to the Xserve

- You need a volume on the Xserve that has
30 megabytes (MB) free and doesn't have
Mac OS X or Mac OS X Server installed

Install AXD EFI tools on a portable storage device

Advantages:

+ You can use AXD EFl tools

+ You can use the same portable storage device
to test multiple Xserve computers

Disadvantages:

« You need physical access to the Xserve

+ You need a volume on the portable storage
device that has 30 MB free and that doesn’'t
have Mac OS X or Mac OS X Server installed

« The portable storage device must be physically
connected to the Xserve
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Option Considerations

Start up the AXD EFI tools located on the Admin
Tools disc

Advantages:

«+ You can use AXD EFI tools

+ You can use the same disc to test multiple
Xserve computers

Disadvantages:

- You need physical access to the Xserve

+ You must insert the disc in the Xserve

+ You can't save logs or take screen shots

Install AXD Mac OS X tools on an internal volume

Advantages:

« You can use AXD Mac OS X tools

« You don't need physical access to Xserve to
run AXD Mac OS X tools remotely (if you have
Apple Remote Desktop)

Disadvantages:

+ You need an empty volume on the Xserve with
7 GB free

« You must install Mac OS X Server on the empty
volume

Install AXD Mac OS X tools on a portable storage
device

Advantages:

» You can use AXD Mac OS X tools

» You can use a single portable storage device to
test multiple Xserve computers

Disadvantages:

+ You need an empty volume on the portable
storage device with 7 GB free

+ You must install Mac OS X Server on the empty
volume

« The portable storage device must be physically
connected to the Xserve

Requirements

Before you can run AXD tools, you must meet general, storage device, and local and

remote requirements.

General Requirements

To run AXD tools, you must have the following:

« An Intel-based Xserve with Mac OS X Server version 10.5 or later installed
« The Mac OS X Server Install DVD and Admin Tools disc included with the Xserve

(both should be version 10.5 or later)

Chapter 1 Overview and Requirements



Storage Device Requirements
Depending on whether you want to run AXD EFI tools, AXD Mac OS X tools, or both,
you need empty volumes on the Xserve or on a portable storage device.

If you want to run AXD Mac OS X tools, the storage device must use the GUID Partition
Table partition scheme. If you're running only AXD EFI tools on the storage device,
you don't need to use the GUID Partition Table partition scheme.

You can run both AXD tools by having two empty volumes on the same Xserve or
portable storage device. You need at least one of the following:

Goal Requirement

Run AXD EFI tools A volume on the Xserve that has at least 30 MB
free, but doesn't have Mac OS X or Mac OS X
Server installed

Run AXD Mac OS X tools An empty volume on the Xserve with at least
7 GB free
Test multiple Xserve computers and run AXD EFI A USB 2.0 flash drive, or USB 2.0 or FireWire hard
tools drive with a volume that has at least 30 MB free
but doesn't have Mac OS X or Mac OS X Server
installed
Test multiple Xserve computers and run AXD A USB 2.0 or FireWire hard drive that has an
Mac OS X tools empty volume with at least 7 GB free

Local and Remote Requirements
To run AXD tools on your local Xserve, you need to attach a keyboard, mouse, and
display.

To run AXD tools remotely, you must have the following:
+ A Macintosh computer with Mac OS X version 10.5.4 or later installed. This computer
is referred to as the host computer.

+ A network connection with DHCP active or a direct Ethernet connection from the
host computer to the Xserve. The Xserve is referred to as the client Xserve.

« If the client Xserve is going to run AXD EFI tools and use a network connection,
the network connection must use a built-in Ethernet port, and not an Ethernet
adapter card.

+ The Xserve must have AXD tools installed either on an internal volume or on a

connected portable storage device; or it must be able to run AXD tools from a
NetBoot server.

« The host computer must run AXD Mac OS X tools. The client Xserve can run AXD EFI
tools or AXD Mac OS X tools.

Chapter 1 Overview and Requirements



+ If the client Xserve is running AXD Mac OS X tools, you must be able to log in as
the root account. The root account gives a system administrator complete access
to the Xserve.

If you want to run AXD tools entirely remotely (for situations where the Xserve is
physically inaccessible or if you want to save AXD EFI tools test results), in addition
to meeting the network requirements, the Xserve must be able to start up Mac OS X
Server.

NetBoot Server Requirements
To host AXD EFI tools on a NetBoot server, your NetBoot server also must:

+ Have Mac OS X Server version 10.5.4 or later installed.
+ Be on the same subnet as the Xserve being tested.
+ Have 30 MB of hard drive space available for an AXD NetBoot image.

Chapter 1 Overview and Requirements



Setup and Installation

Before you can run AXD tools, you must set up your testing
environment and install AXD.

Make sure you meet AXD requirements before attempting setup and installation.
For more information, see “Requirements” on page 7.

Setting Up a NetBoot Server
Before you set up a NetBoot server, make sure you have an available server that meets
the requirements described in “NetBoot Server Requirements” on page 9.

After you set up a NetBoot server, you install the AXD NetBoot image. Because the
AXD NetBoot image is a special image, you can’t use System Image Utility to delete the
image.

For information about deleting the AXD NetBoot image, see the next section, “Deleting
the AXD NetBoot Image.”

To set up a NetBoot server:

Open Server Admin (located in /Applications/Server/).

If the server that will host NetBoot isn't listed, click the Add (+) button and choose Add
Server. Enter the IP address of the server in the Address field, enter the user name and
password of the server administrator in the User Name and Password fields, and then
click Connect.

Click the disclosure triangle for the server that will host NetBoot.

If NetBoot isn't listed, select the server and click Settings. In the Services pane, select
NetBoot and then click Save.

Select NetBoot, click Settings, and then click General.

In the “Enable NetBoot on at least one port” list, select the Enable checkboxes for the
interfaces that you want to serve the AXD NetBoot images over.



If multiple network interfaces are listed, it’s likely that only one of the interfaces is

on the same subnet as your Xserve. If you're not sure which interface is on the same
subnet, open Network Utility (located in /Applications/Utilities/) on your NetBoot
server and your Xserve. In the Info pane, choose different network interfaces on the
NetBoot server and your Xserve and compare the IP Address fields. Usually, computers
are on the same subnet if their IP addresses start with same numbers (for example,
they both start with 192.168.2).

In the volume list, select the Images checkbox and Client Data checkbox for the
volume that will store the AXD NetBoot image.

The volume must have at least 30 MB free.
Click Save.

9 In the Finder, navigate to the AppleXserveDiagnostics folder on the Admin Tools disc,
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and then open AppleXserveDiagnosticsNetBoot.pkg.
Follow the onscreen instructions to install the AXD NetBoot package.
In Server Admin, select NetBoot, and then click Images.

If the AXD NetBoot image has the same index (listed in the Index column) as another
image, deselect the Enable checkbox for the conflicting image.

Don't change any of the default AXD NetBoot image settings.

Click Start NetBoot.

Deleting the AXD NetBoot Image
You can't use System Image Utility to delete the AXD NetBoot image. Instead, you
must delete the AXD NetBoot image in the NetBoot image folder, which is located at:

/Volumes/volumename/Library/NetBoot/NetBootSP#

Replace volumename with the name of the volume that you're installing the AXD
NetBoot image onto. The number (#) varies depending on whether you're using several
NetBoot volumes. If you're using only one NetBoot volume, the AXD NetBoot image

is located in NetBootSPO. If you're using several NetBoot volumes, the AXD NetBoot
image may be located in another folder (for example, NetBootSP1, NetBootSP4, or
NetBootSP11).

To delete the AXD NetBoot image:
Open the Finder and delete AXD.nbi from the NetBoot image folder.

Chapter 2 Setup and Installation
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Setting Up a Storage Device for AXD Tools Installation

To set up an internal volume or portable storage device for AXD tools installation,
you must have at least 30 MB of available space for AXD EFI tools or at least 7 GB of
available space for AXD Mac OS X tools, which requires installing Mac OS X Server.
These requirements are described in detail in “Storage Device Requirements” on
page 8.

If you're installing AXD Mac OS X tools on one of the volumes, the storage device
should use the GUID Partition Table partition map scheme. To view the storage device’s
partition map scheme, open Disk Utility and select the storage device. Make sure you
select the storage device and not a volume within the storage device. At the bottom
of the Disk Utility window, Partition Map Scheme should be GUID Partition Table.

If you want to repartition an in-use storage device, run Disk Utility from the Mac OS X
Server Install DVD or run Disk Utility while your Xserve is connected to another
computer and is in target disk mode. Both of these methods erase the contents of your
Xserve computer’s hard drive and require you to reinstall and reconfigure Mac OS X
Server.

WARNING: The following instructions could erase all data on your storage device.
Back up critical data before performing the following instructions.

To create empty storage device volumes and correctly format them:
Insert the Mac OS X Server Install DVD.

Open the Install Mac OS X Server application, click Restart, and authenticate if
requested.

The computer restarts and opens the Mac OS X Server Installer.
Select a language and click Next (right-arrow).

Choose Utilities > Disk Utility.

Select the storage device that you want to set up.

Make sure you select a storage device, and not volumes within the storage device.
Volumes within a storage device are indented one level.

Click the Partition tab.

If the partition map scheme of the storage device is not GUID Partition Table and
you're going to install AXD Mac OS X tools, choose something besides “Current”in
the Volume Scheme pop-up menu, then click Options, select GUID Partition Table,
and click OK.

Changing the volume scheme erases all data on the storage device.

Review the partition sizes and adjust them to meet AXD tools storage requirements.

Chapter 2 Setup and Installation
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To do this Do this

Display a partition’s size Click the partition and review the Size field.
Set the size of the partition Edit the Size field.

Create more partitions Select a partition and click the Add (+) button.
Delete partitions Select it and click the Delete (-) button.

Name a partition Select it and enter a name in the Name field. If

you're installing AXD EFI tools, name the volume
AXDEFI3X104.

Because this name is used when selecting which
volume to start up Mac OS X from, choose a
name that identifies the volume as being used
for AXD tools.

You can't rename a partition.

If you're installing AXD EFI tools in a volume, select the volume and choose MS-DOS
(FAT) from the Format pop-up menu.

If you're installing AXD Mac OS X tools in a volume, select the volume and choose
Mac OS Extended (Journaled).

Click Partition.

Choose Disk Utility > Quit Disk Utility, and then choose Mac OS X Installer > Quit
Mac OS X Installer.

After you finish setting up volumes, you can install AXD EFI tools or AXD Mac OS X
tools. For more information, see the following topics:

+ “Installing AXD EFI Tools” on page 13

+ “Installing AXD Mac OS X Tools” on page 14

Installing AXD EFI Tools

Before you install AXD EFI tools, make sure that your storage device has a volume that
has at least 30 MB available, is formatted as MS-DOS (FAT), and is named AXDEFI3X104.
Because the volume will be erased, make sure all important data on the volume is
backed up. For more information, see “Setting Up a Storage Device for AXD Tools
Installation” on page 12.

To perform these instructions, you'll need the Admin Tools disc (version 10.5 or later)
included with the Xserve.

If you're performing this task to install AXD EFI tools on an internal volume on the
Xserve, you'll need administrator access to the Xserve. If you're performing this task to
install AXD EFI tools on a portable storage device, you can use any computer that you
have administrator access to.

Chapter 2 Setup and Installation



If you want to connect a host computer directly to the Xserve, and the host computer
doesn’t provide DHCP service on the port used to directly connect to the Xserve, you'll
need to create a file on the Xserve that assigns an IP address to the Xserve. However,
if the host computer provides DHCP service, don't create this file. For information
about how to find out if a computer is providing DHCP service, see Network Services
Administration at:

www.apple.com/server/macosx/resources

To install AXD EFI tools:
Insert the Admin Tools disc.

Open AppleXserveDiagnosticsEFl.pkg (located on the disc in
/AppleXserveDiagnostics/).

Follow the onscreen instructions, and at the Select Destination step, choose a volume
that has at least 30 MB of space available.

If you're prompted to authenticate, authenticate as a user with administrator privileges.

If you want to connect a host computer directly to the Xserve and the host computer
doesn’t provide DHCP service on the port used to directly connect to the Xserve,
do the following:

a Open TextEdit (located in /Applications/).

b In the body of a new file, enter an IP address that’s not in use by the host computer.
For example, enter:

123123123123

If TextEdit doesn’t open with a new blank file, choose File > New.
¢ Choose Format > Make Plain Text.
d Choose File > Save As.

e Name the file axd_set_ip_address, and then change the location of the file to the
volume with AXD EFI tools installed.

m

f Select”If no extension is provided, use "txt,” and then click Save.

Installing AXD Mac OS X Tools

Before you install AXD Mac OS X tools, make sure that your storage device uses the
GUID Partition Table partition scheme and that it has an empty volume with 7 GB of
available space. For more information, see “Setting Up a Storage Device for AXD Tools
Installation” on page 12.

If you're performing this task to install AXD Mac OS X tools on an internal volume on
the Xserve, you'll need administrator access to the Xserve. If you're performing this task
to install AXD Mac OS X tools on a portable storage device, you can use any computer
that you have administrator access to.

Chapter 2 Setup and Installation
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Installing AXD Mac OS X tools involves three steps:

+ Install Mac OS X Server with minimal options selected

+ Copy AXD Mac OS X tools from the Admin Tools disc to /Applications/
+ Configure Mac OS X Server

By dedicating a minimal installation of Mac OS X Server for use with AXD Mac OS X
tools, you reduce the risk of server processes interrupting AXD testing.

To install AXD Mac OS X tools:
Insert the Mac OS X Server Install DVD.

Open the Install Mac OS X Server application, click Restart, and authenticate if
requested.

The computer restarts and opens the Mac OS X Server Installer.
Continue through the Installer until you reach the Select Destination step.

Select a volume that’s at least 7 GB. If the volume isn't empty, click Options, select
“Erase and Install,” and then click OK. Click Continue.

In Installation Type, click Customize, deselect all checkboxes, and then click Install.

If the volume is very close to 7 GB in size, the Installer might automatically load the
Customize list.

When the Installer finishes installing Mac OS X Server, the computer restarts and the
Mac OS X Server setup assistant opens.

In the Server Configuration step of the setup assistant, select Advanced.

Continue through the setup assistant and enter information as requested. Don't enable
any services.

When you finish entering information in the setup assistant, the login window appears.

Log in with the user name “root” and the password of the user you created in the
setup assistant.

You must set up and run AXD Mac OS X tools as root. Otherwise, you won't be able to
test the Xserve you've installed AXD Mac OS X tools on.

Insert the Admin Tools disc.

If you have a disc image of the Admin Tools disc, double-click the .dmg file to mount
the disc image.

Open the Finder and drag the AXD.app file from /AppleXserveDiagnostics/ on the
Admin Tools disc to the /Applications/ folder.

If you're setting up a client Xserve, open the Finder, select the /Applications/ folder,
and choose New Folder from the Action (gear) pop-up menu. Name the folder
AXDClient.

Client Xserve computers are remotely controlled by host computers.

Chapter 2 Setup and Installation
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12 Open System Preferences (located in /Applications/). Change the following options in
System Preferences panes.

System Preferences pane Recommended configuration

Accounts Select the System Administrator account,
and click Login Items. Click Add (+), select
/Applications/AXD.app, and click Add.

CDs & DVDs In all pop-up menus, choose Ignore.

Desktop & Screen Saver In the Screen Saver pane, drag the “Start screen
saver” slider to Never.

Energy Saver In the Sleep pane, drag both sliders to Never, and
deselect “Put hard disk(s) to sleep when possible.”

Exposé and Spaces In the Exposé pane, in all pop-up menus, choose
“—"In the Spaces pane, deselect Enable Spaces.

Software Update In the Scheduled Check pane, deselect “Check for
updates.”

If you can't change settings in System Preferences, click the lock button and
authenticate.

After installing the AXD Mac OS X tools, you must log in as root to run AXD tools to
test your own Xserve. If you don't log in as root, AXD Mac OS X tools enters host mode
and waits for a connection to a client Xserve to control.

Chapter 2 Setup and Installation



Starting Up AXD Tools

This chapter describes several methods that let you change
the startup disk to the volume with AXD tools installed.

Before you start up AXD tools, make sure you've properly installed and configured the
tools. For more information, see Chapter 2,“Setup and Installation,” on page 10.

Changing the Startup Disk

AXD tools is usually installed on a dedicated volume to minimize the risk of server
processes interrupting the tests. Because of this, you'll need to change the startup disk
to the volume with AXD tools installed before you can use the tools.

If you want to test a client Xserve remotely, you'll need to first start up AXD tools on
the host computer, and then start up AXD tools on the client Xserve.

To start up AXD tools, set the startup volume of the Xserve to the volume or disk
image containing AXD tools. If Mac OS X Server starts up by default on your Xserve,
you can change the startup disk in the Startup Disk pane of System Preferences.
Otherwise, you can temporarily change the startup disk by pressing and holding one
of several keys when starting up the Xserve:

Goal Press and hold this key at Xserve startup

Choose the AXD tools volume before starting up  Option
Mac OS X

Start up the AXD EFI tools located on the Admin D (make sure the Admin Tools disc is inserted)
Tools disc

Start up using the AXD EFI tools disk image from  F1 or a specific combination of the Xserve front
a NetBoot server panel buttons

The Startup Disk pane of System Preferences can start up AXD Mac OS X tools, but not
AXD EFI tools. You can press the Option key at startup to start up either AXD EFI tools
or AXD Mac OS X tools.
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The Xserve becomes unavailable whenever you use AXD tools. Before starting tests,
alert your users that the server will be unavailable.

Changing the Startup Disk in System Preferences

If Mac OS X Server starts up by default on your Xserve, you can use System Preferences
to change the startup disk. The list of startup volumes includes internal volumes and
connected portable storage device volumes.

When you change the startup disk in System Preferences, you can't select a startup
disk with AXD EFI tools installed. To change the startup disk to the volume with
AXD EFI tools installed, change the startup disk at startup. For more information,
see “Changing the Startup Disk Temporarily at Startup” on page 19.

To change the startup disk in System Preferences:
Open System Preferences on the Xserve, and then select Startup Disk.

If the lock icon is locked, click it, and then authenticate as a system administrator.
Select the startup disk with the AXD tools and click Restart.

When you're done using AXD tools, change the startup disk back to the volume you
were using previously.

Changing the Startup Disk Using the Command-Line Interface

If Mac OS X Server starts up by default on your Xserve, you can use the command-line
interface to change its startup disk. You can use the command-line interface to start
up from internal volumes and connected portable storage device volumes.

You can also change the startup disk of a remote server using the command-line
interface. Remote login must be enabled on the remote server (enabled by default).
You can enable remote login in the Sharing pane of System Preferences.

When you change the startup disk using the command-line interface, you can't select
a startup disk with AXD EFI tools installed. To change the startup disk to the volume
with AXD EFI tools installed, change the startup disk at startup. For more information,
see “Changing the Startup Disk Temporarily at Startup” on page 19.

You'll need to be able authenticate as the root account to change the startup disk in
the command-line interface.

Note: The Terminal commands described in this task are case-sensitive and must be
entered as shown.

Chapter 3 Starting Up AXD Tools



To change the startup disk using the command-line interface:
Open Terminal (located in /Applications/Utilities/).

If you want to connect to a remote server, enter the following in the Terminal window,
and authenticate when requested:

ssh usernamelserveraddress

Replace username with the short name of a user who can authenticate as the root
account on the server. Replace serveraddress with the URL, IP address, or host name of
the server.

Enter the following, and authenticate as the root account when requested:

sudo bless -folder "/Volumes/volumename/System/Library/CoreServices"
-setBoot

Replace volumename with the name of the volume you want to start up from.

When you're done using AXD tools, change the startup disk back to the volume you
were using previously.

Changing the Startup Disk Using Apple Remote Desktop
If you have Apple Remote Desktop, you can change the startup disk of remote
computers to an internal volume or connected portable storage device volume.

For information about using Apple Remote Desktop to set a computer’s startup disk,
see Apple Remote Desktop Administrator’s Guide, located at:

www.apple.com/remotedesktop

Changing the Startup Disk Temporarily at Startup

If your Xserve has trouble starting up Mac OS X Server or doesn’t Mac OS X Server
installed, you can temporarily change the startup disk by pressing and holding a key
while the Xserve is starting up. This method requires that you have a keyboard and
mouse attached to the Xserve and that you can restart the Xserve.

If you don't have a keyboard and mouse attached to the Xserve, use the instructions in
the next section, “Starting Up an AXD EFI Tools NetBoot Image Using the Xserve Front
Panel.”

If a firmware password is set, you can’t temporarily change the startup disk by pressing
and holding the D or F1 key. You can do it by pressing and holding the Option key, but
you must authenticate with the firmware password.

For information about disabling the firmware password, see “Disabling the Firmware
Password” on page 22.

Chapter 3 Starting Up AXD Tools
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To temporarily change the startup disk at startup:
Restart the Xserve.
While the Xserve is restarting, press and hold the Option key until a list of volumes

appears. If you're asked to authenticate, enter the firmware password and click the
Continue (right-arrow) button.

If you have the Admin Tools disc inserted, you can start up using AXD EFl tools located
on the disc by pressing and holding the D key instead of the Option key.

If you want to start up AXD EFI tools from a NetBoot image hosted on a NetBoot
server, press and hold the F1 key instead of the Option key.

Each of these alternatives immediately starts up AXD EFl tools and bypasses the list of
volumes described in the next step.

If you displayed the list of volumes instead of immediately starting up AXD tools,
select the volume with AXD tools, and then click the arrow button to start up.
The AXD EFI tools volume is listed as EF| Boot.

After you're done using AXD EFI tools and restart the Xserve, it starts up from the
default startup volume.

Starting Up an AXD EFIl Tools NetBoot Image Using the Xserve Front
Panel

You can use the Xserve front panel buttons to start up an AXD EFI tools disk image
hosted by a NetBoot server. This technique is useful for situations where your Xserve:

+ Doesn’t have a monitor or keyboard attached
+ Doesn't respond to keyboard input
+ Doesn't have Mac OS X Server installed

The Xserve must be on the same subnet as the NetBoot server hosting the AXD EFI
tools disk image.

If the Xserve EFI requires a password, you won't be able to start up a NetBoot image
using the front panel. You'll need to disable the firmware password before you can use
the front panel. To disable the password, you must be able to start up Mac OS X Server
on the Xserve.
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To use the Xserve front panel to start up an AXD EFI tools NetBoot image:
1 Turn off the Xserve.

2 Press and hold the system identifier button and press the on/standby button.

On/standby System identifier
button button

@@ @ =3¢ & :1n000000000000000000000 3 000001000000000000 ’

.l L [ ©

3 Continue holding the system identifier button until the top row of lights blink right to
left. Release the system identifier button.

® @ ® ® 6 O O O

o o0 o o0 0 O O O

Top row of lights blink right to left,
then left to right.

If the two rows of lights on the front panel blink once and the Xserve resumes its
startup sequence, a firmware password is enabled. You'll need to disable the password.

For information about disabling the firmware password, see the next section,
“Disabling the Firmware Password.”

Both rows of lights blink once.
Disable the firmware password.

4 When you release the system identifier button, the lower-right light should turn on.
O O O O O O O O

O O O O O O O e

Lower-right light comes on.

5 Press the system identifier button again. The lights in the bottom row should now be
blinking right to left.

o0 O o0 O O 0 O

® ® ® ® © O O O

Bottom row of lights blinks right to left.

6 Press the button repeatedly until the lower-left light turns on.

o o0 O O O O O O

® O O O O O O O

Lower-left light comes on.
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7 When the lower-left light is on, press and hold the system identifier button until all the
lights in the top row are on. Release the system identifier button.

o O O O O O O C

Top row of lights comes on.
When you release the button, the Xserve starts up from the AXD EFI tools NetBoot disk
image.

After you run AXD EFI tools and restart, the Xserve starts up from its default startup
volume.

Disabling the Firmware Password
If a firmware password is enabled, you can't:

« Start up from an AXD EFI tools NetBoot image using the Xserve front panel
+ Temporarily change the startup volume by pressing and holding F1 or D at startup

If a firmware password is enabled and you try to temporarily change the startup
volume by pressing and holding Option at startup, you must authenticate.

To disable the firmware password:
1 Insert the Mac OS X Server Install DVD.

2 Open the Install Mac OS X Server application, click Restart, and authenticate,
if requested.

The computer restarts and opens the Mac OS X Server Installer.
3 After selecting a language, choose Utilities > Firmware Password Utility.
4 In Firmware Password Utility, click Change.

5 Deselect “Require password to change firmware settings,” and click OK. Authenticate
when asked.

6 Choose Firmware Password Utility > Quit Firmware Password Utility.

7 Choose Mac OS X Installer > Quit Mac OS X Installer. Click Startup Disk, select the
startup disk with Mac OS X Server installed, and then click Restart.
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Using AXD Tools 4

AXD Mac OS X tools and AXD EFI tools have different
interfaces and functionality. This chapter describes how to
use both sets of AXD tools.

Before you can use AXD tools, make sure you've properly started up the tools.
For more information, see Chapter 3,“Starting Up AXD Tools,” on page 17.

Setting AXD to Host, Client, or Local Mode

AXD tools can start up in any of three modes, depending on whether:

You're opening AXD EFI tools or AXD Mac OS X tools

Any of the computers on the same subnet are host computers

A host computer is directly connected

You're logged in as root

You're running AXD Mac OS X tools on a computer that isn't an Intel-based Xserve
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The following table describes the three modes:

Mode Description Automatically enters mode if

Host The computer searches for You run AXD Mac OS X tools
Xserve computers that are on and either:
the same subnet and start AXD . The computer isn't an Intel-
tools in remote mode. When based Xserve
one is found, the host computer . youy're not logged in as root
controls AXD tools on the client

Xserve.
Client The Xserve can be controlled by You're running AXD EFI tools
a host computer. and a host computer is on
the same subnet or is directly
connected.
Local The Xserve runs all tests locally.  You're running AXD EFI tools

and a host computer isn't on the
same subnet and isn’t directly
connected.

If you're logged in as root on an Intel-based Xserve, and then you run AXD Mac OS X
tools, you can choose which mode to enter.

Remotely Testing a Client Xserve

If you want to test a client Xserve, you must first start up AXD tools on the host
computer, set it to connect to a client Xserve, and then start up the AXD tools on the
client Xserve and set it to be a client of a remote host.

The host computer must run AXD Mac OS X tools. The client Xserve can run AXD EFI
tools or AXD Mac OS X tools. The available tests are based on which AXD tools the
client Xserve is running.

When you start up AXD EFI tools, the Xserve first looks for a host computer. If it finds
a host computer, the Xserve enters client mode. If it doesn't find a host computer, the
Xserve enters local mode.

When you start up AXD Mac OS X tools, the Xserve automatically becomes a host
computer if either of the following are true:
 You logged in to Mac OS X with an account that isn't root.

+ You are running AXD Mac OS X tools on a computer that isn't an Intel-based Xserve.

If AXD Mac OS X tools doesn’t automatically become a host computer, it asks if it
should connect to a client Xserve, be a client of a remote host, or run tests locally.

To remotely test a client Xserve:
On the host computer, open AXD Mac OS X tools (located in /Applications/).
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2 If the host computer is an Intel-based Xserve and you're logged in as root, when AXD
Mac OS X tools opens, a dialog asks you to choose which mode to enter. Choose
“Connect to remote Xserve”and click OK.

If your computer isn't an Intel-based Xserve, the dialog doesn’t appear, and AXD
Mac OS X tools automatically enters host mode.

3 On the client Xserve, change the startup disk to a volume with AXD tools and restart it.

You can also temporarily change the startup disk to either a volume with AXD tools on
it or to an AXD tools NetBoot disk image when you start up the Xserve.
For more information about how to change or temporarily change the startup volume,
see Chapter 3,”Starting Up AXD Tools,” on page 17.

4 If you're starting up AXD Mac OS X tools, log in as root, and if AXD Mac OS X tools
doesn’t open automatically, open the AXD application (located in /Applications/).
Choose “Client of a remote host,” and then click OK.

5 If you're starting up AXD EFI tools, the Xserve automatically enters client mode.

There are several ways to determine whether the host computer and client Xserve

have established a successful connection:

+ The IP address field in the AXD window on the host computer should match the IP
address assigned to the client Xserve.

+ The name of the AXD window on the host computer is “AXD remote log,” not “AXD
local log.”

+ The log area of the client Xserve uses more of the AXD window. Shut Down, Restart,
and a few other buttons are removed.

Testing the Local Xserve Using AXD EFI Tools

To test the local Xserve, make sure none of the computers on the same subnet as
the Xserve is running AXD Mac OS X tools in host mode. If a computer on the same
subnet is running AXD Mac OS X tools in host mode, the Xserve automatically enters
client mode.

To test the local Xserve using AXD EFI tools:
= Restart the Xserve and press and hold a key, or use the Xserve front panel buttons to
start up the volume or NetBoot disk image with AXD EFI tools.

For more information about how to temporarily change the startup volume while
starting the computer, see Chapter 3,”Starting Up AXD Tools,” on page 17.

When AXD EFI tools starts up and doesn’t find a host computer, it enters local mode.

Testing the Local Xserve Using AXD Mac OS X Tools
To test the local Xserve, you must log in as root. If you don't log in as root, AXD
Mac OS X tools automatically enters host mode.
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To test the local Xserve using AXD Mac OS X tools:
1 Change the startup disk of the Xserve to a volume with AXD Mac OS X tools, restart it,
and log in as root.

2 If AXD Mac OS X tools doesn’t open automatically, open it (located in /Applications/).

3 When AXD Mac OS X tools opens, choose “Local” from the dialog that appears and
click OK.

Using AXD EFI Tools

In AXD EFI tools, the test controls and test selections are split across two panes.
Regardless of which pane you're looking at, you can do the following:

+ View the test log, test settings, and status
- Start tests

+ Clear the test log

+ Restart the Xserve

« Shut down the Xserve

Detailed status

Test controls

Test Selections list ———

Test

Test category

Test log

Select All and
Deselect All buttons

For information about AXD EFI tools, see the following topics:
+ “Customizing AXD EFI Tools Test Settings” on page 27
+ “Clearing the Test Log” on page 28
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+ “Viewing the Hardware Profile” on page 28

+ “Shutting Down or Restarting the Xserve”on page 28
+ “Viewing Saved Logs” on page 28

+ "Taking Screen Shots” on page 29

Customizing AXD EFI Tools Test Settings

You can customize AXD test settings in several ways by choosing which tests are run,
whether to loop tests, and whether to stop or continue testing when an error occurs.

To customize AXD EFI tools test settings:
1 In AXD EFI tools, select the test settings you want.

To do this Do this

Choose which tests are run Do any of the following:

- To select a test, select the checkbox next to
the test.

- To select a specific test within a category of
tests, click the disclosure triangle next to the
category, and then select individual tests.

«+ To select all tests, click Select All.

« To remove all tests, click Deselect All.

Loop all selected tests Do one of the following:

- To loop all selected tests a specific number of
times, select “Loop # times” and replace # with
the number of times to loop.

« To run all tests once, select “Loop # times”and
replace # with the number 1.

- To loop all tests for a specific amount of time,
select “Loop for # hours and # minutes”and
replace # with number of hours and minutes
to loop. When the specified time is reached,
the current loop must complete before the
tests stop. For example, if one loop of your
test set takes 2 hours to complete, and your
specified time is 3 hours, AXD stops testing in
4 hours. (Instead of stopping at 3, it waits for
the current test set loop to complete before
stopping.)

Change what to do when an error occurs In the On Error pop-up menu, do one of the
following:

- To stop testing when the first error occurs,
choose Stop.

- To continue testing when errors occur, choose
Continue.

2 To run the test, click Test.
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Clearing the Test Log
The test log contains all test messages that have occurred during the current AXD
session. If you quit AXD, the log is cleared.

To clear the test log without quitting AXD, click Clear Test Data.

Viewing the Hardware Profile
The hardware profile lists all hardware components in the Xserve.

You can view the hardware profile by choosing Hardware Profile > Display Hardware
Profile.

Shutting Down or Restarting the Xserve
You can shut down or restart the Xserve in AXD EFI tools.

To shut down or restart the Xserve, click Shut Down or Restart.

Viewing Saved Logs

Whenever you start AXD EFI tools, it automatically creates a log of its test results in

the /AXDLogs folder of the volume with AXD EFI tools installed. This log is continually
updated as tests complete. If the Xserve crashes during tests, you can review the log to
see which test it crashed on.

If you run AXD EFI tools from the Admin Tools disc, NetBoot disc image, or from a
volume that is not in MS-DOS (FAT) format, logs are not saved. For more information
about formatting volumes, see “Setting Up a Storage Device for AXD Tools
Installation” on page 12.

The logs are named:

AXD_date_time_serialnumber.txt

The date and time indicate when AXD EFI tools was started. The time is in Greenwich
Mean Time (GMT) using a 24-hour clock format.

The values use this format:

Value Format Example
date DDMonYear 15Jul2007
time HH_MM_SS 19_23_46
serialnumber A AB12345CD6E
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Taking Screen Shots
You can take screen shots of AXD EFI tools, which are saved as BMP files in the root
folder of the volume with AXD EFI tools installed.

If you run AXD EFI tools from the Admin Tools disc, NetBoot disc image, or from a
volume that is not in MS-DOS (FAT) format, you can't take screen shots. For more
information about formatting volumes, see “Setting Up a Storage Device for AXD Tools
Installation” on page 12.

To take a screen shot:
= |n AXD EFI tools, press Command-Shift-3.

After pressing Command-Shift-3, the system pauses for a few seconds to take the
screen shot.

Using AXD Mac OS X Tools

AXD Mac OS X tools changes based on whether you're running it locally, as a client, or
as a host. In client mode, you can’'t change test settings, select different tests, or shut
down or restart the Xserve. Therefore, the test log uses most of the window.

In local and host mode, you can access all AXD Mac OS X features in the main window.

Local or client IP address Log status Currently viewed log
800 AXD local log - 1
T
System Info: 10.5.5(9F33) IP Address:17.206.132.225 View log: [ © Test—! H G Dl
Start Testing [18 Dec 2008 15:35:15] * TESTING STARTED *
. [18 Dec 2008 15:35:15] Custom: Hardware Existence Ghecl
Detailed status ——status: * All startup tests passed [Elapsed time = - Verifies non-configurable hardware existence.
00:00:00] * Unknown Sensor Found: Temperature - GFU B Core 1(1
~ Power Supplies: 2
Start Time: 19 Dec 2008 15:35:15 Processors: 2
End Time: 19 Dec 2008 15:35:16 Internal Drives: 3
Elapsed Time: 00:00:00 DIMMs: 4

Ethernet Controllers: 2
Optical Drives: 0
Test controls ——on error: [15:35:16]  TestPassed

[18 Dec 2008 15:35:16] Memaory: Check for ECC Errors (test
® - Check to see if any Memory ECC Errors have bee
[15:35:16] Test Passed

¥

OTime: 1 |hrs[2]

: i &) [o min (%] [19 Dec 2008 15:35:16] Memory - DIMM 1/BRANGH 0 CHAI
Test Selections list . . — — - Check SMBIOS for devices that are flagged as hat
Test Selections [15:35:16] Test Passed
Test ————1# Memory: Apple Simple Memory Test ~| 18 Dec 2008 15:35:16] Memory - DIMM 2/BRANCH 0 CHAI
»[] USB Port: USB Port Device Presence Test {connected USB devi - Ghack SWMBIOS for davicas thal are flagged as hay
— [15:35:16 Test Passed
’g Fan [18 Dec 2008 15:35:16] Memory - DIMM 3/BRANGCH 1 CHAI
Test category ————»[] video Controller - Mezzanine - Check SMBIOS for devices that are flagged as hat
. . [15:35:16] Test Passed
PESEnsor. Sensor Reads Within Operating Range 119 Dec 2008 15:35:16]  Memory - DIMM 4/BRANGH 1 GHAI
[ SMC: SMC PID Sensor check - Check SMBIOS for devices that are flagged as har
»[=] Ethernet Controller [15:35:16) Test Passed
'E Hard Drive [18 Dec 2008 15:35:16] * All startup tests passed [Elapsed tim
PE Power Supply
Test log
[ ) Jalr]
Select All and — (+] -] Tests selected: 124 of 144 === T
Deselect All buttons
Test Croup: (Defaut :
A

For information about using AXD Mac OS X Tools, see the following topics:
+ “Customizing AXD Mac OS X Tools Test Settings” on page 30

+ “Working with Test Groups” on page 31
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- "Viewing Logs” on page 32

+ “Setting Log Preferences” on page 33

+ “Shutting Down or Restarting the Xserve” on page 34

+ “Quitting AXD Mac OS X Tools While a Test is Running” on page 34

Customizing AXD Mac OS X Tools Test Settings
You can customize AXD test settings in several ways by choosing which tests are run,
whether to loop tests, and whether to stop or continue testing when an error occurs.

To customize AXD Mac OS X tools test settings:
1 In AXD Mac OS X tools, select the test settings you want.

To do this Do this
Choose which tests are run In the Test Selections list, do the following:
- To select a test, select the checkbox next to
the test.

- To select a specific test within a category of
tests, click the disclosure triangle next to the
category, and then select individual tests.

« To select all tests, click the Select All (+) button.

« Toremove all tests, click the Deselect All (-)
button.

Loop all selected tests Select “Loop tests by,” and then do the following:

- To loop all selected tests a specific number
of times, select Count and enter a number of
times to loop.

- To loop all selected tests for a specific amount
of time, select Time and enter the number
of hours and minutes to loop. When the
specified time is reached, the current loop
must complete before the tests stop. For
example, if one loop of your test set takes 2
hours to complete and your specified time is
3 hours, AXD Mac OS X tools stops testing in
4 hours. (Instead of stopping at 3, it waits for
the current test set loop to complete before
stopping.)

Change what to do when an error occurs In the On Error pop-up menu, do the following:

- To stop testing when the first error occurs,
choose Stop.

- To continue testing when errors occur, choose
Continue.

2 To save your customized test settings for future use, in the Test Group pop-up menu,
choose Save Current Group. Enter a name for the group and click OK.

For more information, see the next section, “Customizing AXD Mac OS X Tools Test
Settings.”
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3 To run the test, click Start Testing.

4 When the test completes, a PASSED or FAILED message appears on screen. Click

anywhere to close the message.

If you stop the test before it completes, no message appears.

Working with Test Groups

You can create test groups based on your customized test settings. These are similar
to templates because they allow you to reuse your test settings without having to
change each setting individually. After choosing a test group, you can still change its

settings.

There are several test groups included with AXD Mac OS X tools. These test groups
stop when an error occurs, and they aren’t looped.

Test group

Test selections

Default All memory, fan, hard drive, sensor, SMC PID
sensor, and power supply tests. Ethernet
MAC address verification and ROM checksum
verification.

Quick Test All sensor tests.

You can also export a test group to a file. By exporting a test group, you can use that
file to re-create that test group on other AXD installations. For example, if you install
AXD Mac OS X tools on several Xserve computers, you can copy the test group file to
each of them, making identical tests available without having to manually create a

new test group.

To work with test groups:

= |n AXD Mac OS X tools, choose the options you want.

To do this

Use a test group

Do this

In the Test Group pop-up menu, choose a test
group.

Create a new test group

In the Test Group pop-up menu, choose Save
Current Group. Enter a name for the group and
click OK.

Delete a test group

In the Test Group pop-up menu, choose a test
group. Choose Edit > Delete Test Group.

You can't delete the Default or Quick Test test
groups.

Export a test group

Choose File > Export Test Group, choose a
location, name the test group, and click Save.

Import a test group

Choose File > Open, select an .axdconfig file, and
click Open.
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Viewing Logs
You can view the following types of logs in AXD Mac OS X tools:

Log type Description

Test All messages from tests run in the current AXD
Mac OS X tools session.

Hardware Info Listing and description of all installed hardware.

System All of the logs that are also available in System
Profiler (located in /Applications/Utilities/)

You can also view logs stored on other volumes. This is useful for:

+ Starting up AXD Mac OS X tools from a USB drive or a disc, and viewing logs stored
on the Xserve startup volume

+ Diagnosing issues that you run into while you're not using AXD tools

When you view logs in AXD Mac OS X tools, a colored circle next to the log name
indicates whether the log is able to be loaded.

Color Status

No circle You haven't loaded the log during this AXD
session, or the log hasn't been created yet.

Yellow The log didn't load. This usually occurs when
there isn't any data in the log.

Green The log loaded.

To view logs:
Open AXD Mac OS X tools.

If tests are currently running, wait for them to complete or stop them.
If tests are running, you can view only the test log.

Do any the following:

To do this Do this

Choose a different volume to view logs on Choose Logs > View Different System’s Logs,
choose a volume from the “Volume to gather
system logs from” pop-up menu, and click OK.

View logs in the current or chosen volume Choose a log from the “View log” pop-up menu.

Search for specific text within the log Enter text in the search field. When you press
Return, matching text is highlighted in the log
area.
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To do this Do this

Clear logs Choose Logs > Clear current Log, or choose Logs
> Clear All Logs.
The name of the currently viewed log replaces
current.

Refresh logs Choose Logs > Refresh Current Log, or choose
Logs > Refresh All Information Logs.

Setting Log Preferences

You can set up log preferences so that the AXD test logs are automatically saved to a
file at a location you choose. AXD test logs are created every time you start a new AXD
session.

When AXD Mac OS X tools saves a log, it overwrites any existing log of the same name.
Log preferences can automatically customize the name of the log file so that the log
files aren’t overwritten.

If you don’t use any of the naming options, the log is saved as:

AXD_serialnumber_mode_autosave_log.txt

If you are testing locally, mode is replaced by “local.” If you are testing remotely, mode is
replaced by “remote.”

If you use all of the naming options, the log is saved as:

AXD_serialnumber_mode_autosave_log_date_ethernetaddress uniquename.txt

The appended values use this format:

Value Format Example

date DD_Mon_Year 15_Jul_2007
ethernetaddress #H#H #H 01_23_45_67_89_ab
uniquename -# -1

The unigue name will be appended only if a file of the same name exists.

A log for the local Xserve with all naming options enabled (using the example values)
is saved as:

AXD_AB12345CD6E_local_autosave_log_15_Jul_2007_01_23_45_67_89_ab - 1.txt
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To set log preferences:
In AXD Mac OS X tools, choose AXD > Preferences.

To automatically save test logs, select “Auto-save test log.”
If you don't select this option, you can’t perform the steps that follow.

To choose the location of the automatically saved log, click “Choose auto-save
location,” select a location, and then click Open.

Configure the test log naming options.

To do this Do this

Ensure newly created log files don't overwrite old  Select “Use unique name.”
log files

Append the Ethernet address of the Xserve that’s ~ Select “Append Ethernet Address.”
being tested

Append the run time and date of the session’s Select “Append time and date.”
first tests

Shutting Down or Restarting the Xserve
If you're running AXD Mac OS X tools on the local Xserve, or on a host computer, you
can shut down or restart the Xserve.To do so, click Shut Down or Restart.

If the Xserve is in client mode, you can't shut down or restart the Xserve locally.

Quitting AXD Mac OS X Tools While a Test is Running

If you try to quit AXD Mac OS X tools while a test is running, you won't be able to print
or save any logs from the current AXD session. Make sure you print or save any critical
logs before quitting.

Instead of quitting in the middle of a test, you can stop the current test, print or save
logs, and then quit.
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AXD Tools Test Reference

Appendix

This reference describes all the tests available in AXD tools
and gives estimates for how long the tests take to complete.

The types of tests available depend on if you're using AXD EFI tools or AXD Mac OS X
tools, and on your Xserve model and configuration.

Comparison of Available Tests

The following table compares the tests available by component, depending on if
you're using AXD EFI tools or AXD Mac OS X tools. For more information about the
specific tests available for each component, see “AXD EFI Tools Tests” on page 37 and
“AXD Mac OS X Tests” on page 43.

A v indicates that a test is available, and a blank entry indicates that there are no tests
available:

Component tested Available in AXD EFI Available in AXD Notes
tools Mac OS X tools
Boot ROM v
Ethernet controller v v Different tests are
available depending on
the tool.
Fan v
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Component tested Available in AXD EFI Available in AXD Notes
tools Mac OS X tools

Hard drive v v Different tests are
available depending on
the tool.

Memory (simple) v v In AXD EFI tools, this
tests only the first 2.5
GB of memory using a
single CPU core.
In AXD Mac OS X tools,
this tests all memory
using a single CPU core.

Memory (multicore) v v In AXD EFI tools, this

tests the first 2.5 GB

of memory using all
available CPU cores.

In AXD Mac OS X tools,
this tests all memory
using all available

CPU cores.

Memory (extended) v

Tests all memory.

Memory (SMBIOS) v v Tests if memory has
been mapped out
correctly.

Memory (ECC) Tests for memory ECC
errors.

Power supply v v

Sensor v v AXD Mac OS X tools has

an additional sensor
test.

SMC PID sensor

USB port

Video controller

SIS

AXD Mac OS X tools has
more tests than AXD
EFI tools.
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AXD EFI Tools Tests

These tests are available if your Xserve is running AXD EFI tools.

Startup Tests

These tests run automatically when you start up AXD EFl tools.

SMBIOS tests check to see if bad memory was detected and mapped out at Xserve
startup. When the Xserve tests memory at start up, it automatically maps out bad

memory. Mac OS X doesn't see this mapped-out memory, so the non-SMBIOS memory

tests don't test it. The SMBIOS test reports these mapped-out DIMMS.

When an ECC error occurs, memory catches the problem and and fixes it. When you
run other memory tests, the tests don't realize an error has occurred. The ECC tests
detect these memory fixes and report them.

Test

Hardware Existence

Estimated completion time

1 second

Description

Compares a table of sensors and
fans with what is connected to
the logic board. If a sensor or
fan isn't found, an error occurs.

All sensors found can be

individually tested using
sensor tests.

SMBIOS Self-Test

1 second

Checks the SMBIOS tables for
32-bit errors (type 18) and 64-
bit errors (type 33). Also verifies
that the mapped-in DIMM size
is appropriate for the slot it's
inserted into. If there’s a size
mismatch, an error occurs.

ECC Error Count

1 second

Reports the number of ECC
errors, and then resets the
count.
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Boot ROM Tests

Test Estimated completion time Description

Boot ROM Checksum 1 second Verifies the Boot ROM
checksum.

Boot ROM FW GUID MAC Addr 1 second Verifies the Boot ROM FireWire

Checksum GUID MAC address checksum.

Ethernet Controller Tests
The availability of Ethernet controller tests depends on the Enternet controller installed
in the Xserve.

Test Estimated completion time Description

MAC Address Verification 1 second Verifies MAC address isn't all FFs
or 00s.

PCI-E 1 LinkWidth Verification 1 second Verifies PCl link width is 1.

PCI-E 2 LinkWidth Verification 1 second Verifies PCl link width is 2.

PCI-E 4 LinkWidth Verification 1 second Verifies PCl link width is 4.

PCI-E 2.5G Link Speed 1 second Verifies PCl link speed is 2.5G.

Verification

Hard Drive Tests
When AXD EFI tools starts, it performs a hardware existence test. All hard drives found
during this test can be tested individually using hard drive tests.

Test Estimated completion time Description
Full Read 21 minutes for an 80 GB drive; Performs a DMA full-read scan
3 hours for a 1 TB drive at 1250 RPM. This checks the
entire hard drive for slow-read
failures.

This test is available for hard
drives, not solid-state drives.

Abbreviated Read 1 minute Performs a DMA scan at 1250
RPM. This checks the first 10 GB
of the hard drive for slow-read
failures.

This test is available for hard
drives, not solid-state drives.
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Memory Tests
All memory tests are listed under Memory. These tests are described here.

Simple Memory Tests
Simple memory tests test the first 2.5 GB of memory. To test all memory, run extended
memory tests.

Even though simple memory tests don't test all memory, run these tests to detect
intermittent memory issues.

In AXD EFI tools, all memory tests (simple, multicore, and extended) are grouped under
Memory tests.

Note: The time required to complete memory tests correlates to the size of memory
being tested. These estimates are based on testing 1 GB of memory.

Estimated completion time Description

Address as Data 5 seconds Tests memory using the
memory address as data.

Patterns 25 seconds Tests memory using different
data patterns.

Marching Ones and Zeros 15 seconds Tests memory by walking 1s and
0s up and down memory.

Knaizuk Hartmann 10 seconds Tests memory using this
algorithm.

MOD3 30 seconds Tests memory using this
algorithm.

March U 2 minutes Tests memory using this
algorithm.

Random 15 seconds Uses pseudo-random values.

Block Checkerboard 32 10 seconds Alternates 32-bit words with all
1s and all 0s, and then with all
0s and all 1s.

Bit Checkerboard 32 10 seconds Alternates bits with all 1s and
all 0s, and then with all 0s and
all 1s.

Sequential Byte Block 32 14 minutes Fills all bytes sequentially with

patterns starting at 0x00 and
ending at OxFF.

Walking One 32 5 minutes Walks 1s up and down memory.

Walking Zero 32 5 minutes Walks Os up and down memory.
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Test Estimated completion time Description

Walking Spread Bit 32 5 minutes Walks 0b01 up and then walks
0b10 down memory.

Walking Bit Flip 32 5 minutes Alternates words with walking

1 and walking 0, and then
alternates with walking 0 and
walking 1.

Multicore Memory Tests

Multicore memory tests test the first 2.5 GB of memory using all available CPU cores.

In AXD EFI tools, all memory tests (simple, multicore, and extended) are grouped under

Memory tests.

Note: The time required to complete memory tests correlates to the size of memory
being tested. These estimates are based on testing 1 GB of memory.

Test Estimated completion time Description

MP Block Checkerboard 32 5 seconds Alternates 32-bit words with all
1s and all Os, and then with all
0s and all 1s.

MP Bit Checkerboard 32 5 seconds Alternates bits with all 1s and
all 0s, and then with all Os and
all 1s.

MP Sequential Byte Block 32 8 minutes Fills all bytes sequentially with
patterns starting at 0x00 and
ending at OxFF.

MP Walking One 32 2 minutes Walks 1s up and down memory.

MP Walking Zero 32 2 minutes Walks 0s up and down memory.

MP Walking Spread Bit 32 2 minutes Walks 0b01 up and then walks
0b10 down memory.

MP Walking Bit Flip 32 2 minutes Alternates words with walking
1 and walking 0, and then
alternates words with walking 0
and walking 1.

Check Hardware Errors 1 second Tests specific registers for

memory related errors. Running
this test at the end of memory
testing may help catch memory
errors generated during other
memory tests.
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Extended Memory Tests
Extended memory tests test all available memory.

In AXD EFI tools, all memory tests (simple, multicore, and extended) are grouped under
Memory tests.

The availability of extended memory tests depends on the Xserve model you test.

Note: The time required to complete memory tests correlates to the size of memory
being tested. These estimates are based on testing 1 GB of memory.

Test Estimated completion time Description

Extended Memory Test POOF 5 seconds Tests memory using pattern 0.
This fails if an error occurs.

Extended Memory Test POTF 5 seconds Tests memory using pattern 1.
This fails if an error occurs.

Extended Memory Test PO2F 5 seconds Tests memory using pattern 2.
This fails if an error occurs.

Extended Memory Test PO3F 5 seconds Tests memory using pattern 3.
This fails if an error occurs.

Extended Memory Test PO4F 5 seconds Tests memory using pattern 4.
This fails if an error occurs.

Extended Memory Test PO5F 5 seconds Tests memory using pattern 5.
This fails if an error occurs.

Extended Memory Test PO6F 5 seconds Tests memory using pattern 6.
This fails if an error occurs.

Extended Memory Test PO7F 5 seconds Tests memory using pattern 7.
This fails if an error occurs.

SMBIOS Memory Tests

Test Estimated completion time Description

SMBIOS Self-Test 1 second Checks the SMBIOS tables for
32-bit errors (type 18) and 64-
bit errors (type 33). Also verifies
that the mapped-in DIMM size
is appropriate for the slot it's
inserted into. If there’s a size
mismatch, an error occurs.
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Power Supply Tests

Test Estimated completion time Description

Good 1 second Checks if the power supply’s
good bit is set. If it's not set, this
could indicate that the power
supply isn't seated well or is bad,
or that there’s no AC connected.

Quick 5 seconds This is available only if you have
more than one power supply.
This turns off the redundant
power supplies so that only one
power supply is used.

Processor Tests

Test Estimated completion time Description

L1 Cache Test 1 second Verifies that the L1 cache is
good on all processor cores.

Sensor Tests

When AXD EFI tools starts, it performs a hardware existence test. All sensors found
during this test can be tested individually using sensor tests.

Test Estimated completion time

Sensor Reads 1 second

Description

Verifies that the sensor reads are
within the preset sensor limits.

SMC PID Sensor Tests

The System Management Controller (SMC) monitors the Proportional Integral
Derivative (PID) controller which controls several important temperature sensors.

Test Estimated completion time Description

SMC PID Sensor 1 second Verifies that the sensor reads
controlled by the PID are within
the preset sensor limits.

USB Tests

Connect USB devices before running USB tests.

Test Estimated completion time Description

Presence 1 second Verifies that a USB device is

connected.
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Video Controller Tests
The availability of video controller tests depends on the video controller installed in
the Xserve.

Test Estimated completion time Description
PCI-E 8 LinkWidth Verification 1 second Verifies PCl link width is 8.
Framebuffer Address as Data 2 minutes Tests the framebuffer using

framebuffer addresses as data.

AXD Mac OS X Tests

These tests are available if your Xserve is running AXD Mac OS X tools.

Startup Tests
These tests run automatically when you start up AXD Mac OS X tools.

SMBIOS tests check to see if bad memory was detected and mapped out at Xserve
startup. When the Xserve tests memory at start up, it automatically maps out bad
memory. Mac OS X doesn’t see this mapped out memory, so the non-SMBIOS memory
tests don't test it. The SMBIOS test reports these mapped out DIMMS.

When an ECC error occurs, memory catches the problem and and fixes it. When you
run other memory tests, the tests don't realize an error has occurred. The ECC tests
detect these memory fixes and report them.

Test Estimated completion time Description

Hardware Existence 1 second Compares a table of sensors and
fans with what is connected to
the logic board. If a sensor or
fan isn't found, an error occurs.

All sensors, fans, and hard
drives found can be individually
tested using sensor, fan, hard
drive tests.

SMBIOS Self-Test 1 second Checks the SMBIOS tables for
32-bit errors (type 18) and 64-
bit errors (type 33). Also verifies
that the mapped-in DIMM size
is appropriate for the slot it's
inserted into. If there’s a size
mismatch, an error occurs.

ECC Error Count 1 second Reports the number of
ECC errors, and then resets
the count.
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Ethernet Controller Tests
The availability of Ethernet controller tests depends on the Enternet controller installed
in the Xserve.

Data loop tests can add to network traffic. Consider disconnecting from the network
before running the data loop tests.

Test Estimated completion time Description

MAC Address Verification 1 second Verifies MAC address is not all
FFs or 00s.

Ethernet ROM Checksum 1 second Verifies Ethernet ROM checksum
is valid.

MAC Loopback 1 minute Verifies that there’s no data

mismatch between sent and
received data while looping
within the MAC (a sublayer of
the datalink layer in the 1ISO
network reference model).

PHY 1000 Loopback 20 seconds per port, 40 seconds Verifies that there’s no data
total mismatch between sent and

received data while looping
within the physical transport
medium (PHY) at 1000 Mbps.

PHY Jumbo Packet Loopback 20 seconds per port, 40 seconds Verifies that there’s no data
total mismatch between sent and
received jumbo packet data
while looping within the
physical transport medium
(PHY) at the the highest
supported speed.
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Fan Tests
When AXD Mac OS X tools starts, it performs a hardware existence test. All fans found
during this test can be tested individually using fan tests.

Test Estimated completion time Description
Verify Motor +/- 10%, 10 Reads 2 minutes Verifies the minimum and
High, 20 Low maximum fan speeds. Sets the

minimum and maximum builds
within 10% of the threshold and
then does 10 consecutive reads
at the maximum and 20 at the

minimum.
Verify Motor Automatically 2 minutes Verifies the minimum and
+/-15% maximum fan speeds. Sets the

minimum and maximum builds
within 15% of the threshold.

Hard Drive Tests

When AXD Mac OS X tools starts, it performs a hardware existence test. All hard
drives and solid-state drives found during this test can be tested individually using
hard drive tests.

Test Estimated completion time Description
Threaded Surface Scan 21 minutes for an 80 GB drive; Scans the entire surface of a
3 hours for a 1 TB drive hard drive.

This test is available for hard
drives, not solid-state drives.

Threaded Surface Short Scan 1 minute Scans the first 10 GB of a
hard drive.

This test is available for hard
drives, not solid-state drives.

Check SMART Status 1 second Checks the SMART status of a
hard drive.

This test is available for hard
drives, not solid-state drives.
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Test Estimated completion time Description

Short Random Multi-block 2 minutes Performs a threaded, random
multi-block read of random
ranges of the target hard drive.
This is not a full surface scan,
but it will cause rapid seeking
and reading of hard drive
blocks. If a block can't be read,
an error occurs.

This test is available for hard
drives, not solid-state drives.

SSD Threaded Media Scan Not available Scan’s the entire accessible area
of a solid-state drive.
This test is available for solid-
state drives, not hard drives.

SSD New Drive SMART Data Not available Checks the SMART status of a
solid-state drive.

This test is available for solid-
state drives, not hard drives.

Memory Tests
All memory tests are categorized here.

Simple Memory Tests
AXD Mac OS X memory tests test the first 2.5 GB of memory. All multicore memory
tests listed in AXD EFI tools are run.

Even though these tests don't test all memory, run these tests to detect intermittent
memory issues.

After the first 2.5 GB of memory is tested, the memory test then tests for ECC errors.
When an ECC error occurs, memory catches the problem and fixes it. The test detects
the number of memory fixes and reports them.

Note: The time required to complete memory tests correlates to the size of memory
being tested. These estimates are based on testing 1 GB of memory.

Test Estimated completion time Description

Simple Test 12 minutes Runs all multicore memory tests
listed in AXD EFI tools, reports
the number of ECC errors, and
then resets the count.
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SMBIOS Memory Tests

Test Estimated completion time Description

SMBIOS Self-Test 1 second Checks the SMBIOS tables for
32-bit errors (type 18) and 64-
bit errors (type 33). Also verifies
that the mapped-in DIMM size
is appropriate for the slot it's
inserted into. If there’s a size
mismatch, an error occurs.

ECC Memory Tests

Test Estimated completion time Description

ECC Error Count 1 second Reports the number of
ECC errors, and then resets
the count.

Power Supply Tests

Test Estimated completion time Description

Good 1 second Checks if the power supply’s

good bit is set. If it's not set, this
could indicate that the power
supply isn't seated well or is bad,
or that there’s no AC connected.

Quick 5 seconds This is available only if you have
more than one power supply.
This turns off the redundant
power supplies so that only one
is run on.

Sensor Tests
When AXD Mac OS X tools starts, it performs a hardware existence test. All sensors
found during this test can be tested individually using sensor tests.

Test Estimated completion time Description

Sensor Reads 1 second Verifies that the sensor reads are
within the preset sensor limits.
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USB Tests

Connect USB devices before running USB tests.

Test Estimated completion time Description
Presence 1 second Verifies that a USB device is
connected.

Video Controller Tests

To run these tests, a display must be attached to any graphics cards being tested. The
displays can't be in sleep. For example, if you have two graphics cards, they both need
a display attached and both displays must not be in sleep.

Test Estimated completion time Description

OpenGL Point 10 seconds Verifies video controller using a
2D point test.

OpenGL Line 10 seconds Verifies video controller using a
2D line test.
OpenGL Triangle 10 seconds Verifies video controller using a

2D triangle test.

OpenGL Quad 10 seconds Verifies video controller using a
2D quadrilateral test.

OpenGL Quad with Texture 10 seconds Verifies video controller using a
2D textured quadrilateral test.

OpenGL Rectangle 10 seconds Verifies video controller using a
2D rectangle test.

OpenGL Cube 10 seconds Verifies video controller using a
3D cube test.
OpenGL Cube with Fog 10 seconds Verifies video controller using a

3D cube with fog test.

OpenGL Wireframe 10 seconds Verifies video controller using a
3D wireframe test.

OpenGL Solid Red Model 10 seconds Verifies video controller using a
3D solid red model test.

OpenGL Solid Red Model with 10 seconds Verifies video controller using a
Fog 3D solid red model with fog test.
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