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第第一一章章 GGeerrbbeerr 基基本本概概念念  

1.1  什么是 Gerber 文件 

   Gerber 也叫 光绘 通常只代表一种格式如 RS-274, 274D, 274X 等 充当了将设计的

图形数据转换成 PCB 制造的中间媒介 即一种 CAD-CAM 数据转换格式标准 主要用途就是 PCB

版图绘制,最终由 PCB 制作商完成 PCB 的制作 为了更直观了解 Gerber 是如何产生 如何转

换的 我们先来看下图  

 

无论是哪种 CAD 系统 最后都必须将内部 CAD 数据库转换成 GERBER 格式文件 在这个过

程中 Aperture table 描述了绘图机的镜头大小 形状 位置信息 两者的转换通常是无形

的 一旦 Gerber 产生 绘图机就可以开始工作 绘图机是一种较昂贵但很精确的设备 精确

度可以小于 1mil  

1.2  Gerber 的几种常见格式 

   Gerber Format 是电子业之间通用的资料格式 它是被用于设计完成与上线制造 PCB 的中

间体 就像土木或机械五金业常用的 AutoCad 软体所输出的 DXF 或 HPGL 格式一般 是设计师

把图稿设计完成所产生的文件与其它系统连结的工作资料  

   这最初是美国 Gerber 公司自行制定出来给该公司所生产的光学绘图机使用的 也因此而

称为 Gerber Data 但因为格式颇能符合电子业间的需求 也因此大家广泛使用久而久之演

变成为一种业界标准的资料格式 后来因为格式被电子业广为接受 慢慢的大家都称为Gerber 

Format 标准的 Gerber Format 主要有两种  

1). RS-274-D  它是依照 EIA 的 RS-274-D 标准码于 1985 年衍生制定的 而其资料内容包

括 word address 资料及绘图机的参数档与控制码 这种格式的 Gerber 必须包含一个

Aperture 文件 也就是说 Gerber File 和 Aperture 文件是分开的不同文件 RS-274-D 被
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使用至今已有数十年了 因电子产品的演变早已超出当初的需求 因此原有的 RS-274-D 格

式也慢慢的不敷使用 被因此衍生出的强化版 RS-274-X 所替代  

2) RS-274-X  产生于 1992 年 即当今最为流行的资料格式 他是 RS-274-D 的扩展版 是

以 RS-274-D 为基础的 只不过 RS-274-X 格式的 Aperture 整合在 Gerber File 中的

也即 内含 D 码  

除上述的情况外 还有一些数据格式标准正在运用或开发中 如 MDA/Fire9000 Barco DPF

因为不是很常用 在此就不详细介绍了  

 

1.3  Gerber 数据简介 

   Gerber 格式的数据特点  

z 数据码 ASCII EBCDIC EIA ISO 码 常用 ASCII 码  

z 数据单位 英制(English:inch/mil) 公制(Metric:mm) 常用英制  

z 坐标形式 相对坐标 绝对坐标 常用 绝对坐标  

z 数据形式 省前零 定长 省后零 常用 定长  

 

常见数字和字母意义  

D01: LIGHT ON (快门开) 

D02: LIGHT OFF (快门关) 

D03: FLASH 

 

D10~Dn: APERTURE CODE 

G54: 更换镜头 

M02: 结束 

 

几种常见格式范例  

RS-274-D 格式 

G54D10* 

X1000Y1000D02* 

X2000Y2000D01* 

X1000Y2000D02* 

X2000Y1000D01* 

D11* 

X3000Y3000D03* 

 

 

 

M02 

 

RS-274-X 格式 
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%FSLAX55Y55*MOIN*% 

%IR0*IPPOS*OFA0.00000B0.00000*MIA0B0*SFA1.00000B1.00000*% 

%ADD10C,.011811*% 

%ADD11C,.019685*% 

%ADD12C,.005906*% 

%ADD13C,.006*% 

%ADD14C,.03937*% 

%ADD15C,.003937*% 

G75*  

%LPD*% 

G75* 

G54D10* 

G01X-36184Y409646D02* 

X-34944Y408605D01* 

X-33549Y407980D01* 

X-32309D01* 

X-31069Y408605D01* 

X-30139Y409646D01* 

 

G54D19* 

X501370Y52850D03* 

X503929D03* 

X506488D03* 

X509047D03* 

 

M02* 

 

Gerber File 极性介绍  

正片(Positive): Gerber 描述的是线路层 并且描述之图形主要是有铜部分 或 Gerber

描述的是阻焊层 并且描述之图形主要是防焊部分(即盖油墨部分)  

负片(Negative): Gerber 描述的是线路层 并且描述之图形主要是无铜部分 或 Gerber

描述的是阻焊层 并且描述之图形主要是无防焊部分(即不盖油墨部分)  

复合片(Compostive): Gerber所描述的层次有不同极性层合成 通常是挖层和正极性叠加

挖层极性为 c 主要起线路防护或追加制成资料等作用  

 

镜头档(Aperture File)介绍  

镜头档主要描述相应 Gerber File 所用镜头的形状和大小 

Aperture File + Gerber File =完整的 PCB Layout 图形 

常用字段 D_CODE: D 码 即镜头编号  
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          SHAPE: 镜头形状  

          SIZE: 镜头大小  

基本镜头  

 

 

钻孔档(Drill File)介绍  

常见钻孔及含义  

PTH---镀通孔 孔壁镀覆金属而用来连接中间层或外层的导电图形的孔  

NPTH---非镀通孔 孔壁不镀覆金属而用于机械安装或机械固定组件的孔  

VIA---导通孔 用于印制板不同层中导电图形之间电气连接(如埋孔 盲孔等) 但不能插

装组件引腿或其它增强材料的镀通孔  

盲孔---仅延伸到印制板的一个表面的导通孔  

埋孔---未延伸到印制板表面的导通孔  

 

 

 

 

 

 

 

 

第第二二章章 CCAAMM335500  简简介介  

今天的电子产品设计日趋复杂 要求体积更小 速度更快 设计加工开销更小 它需要

细心地传递工程数据到 PCB 加工过程中去 CAM350 提供了从 PCB 设计到 PCB 加工制造全面的

流程 指导 PCB 的生成加工 CAM350 提供的工具即支持 PCB 设计师(CAM350 for Engineering)

又支持 PCB 制造者(CAM350 for Fabrication) 它非常容易地建立 PCB 制造工程中统一的数

据 并贯穿整个 PCB 加工制造过程  因此 CAM350 是 PCB 设计者和制造者使用的完整的 PCB

制造加工流程中的一个主要工具  
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CAM350 系列软件是一个易于学习 功能强大的软件工具 它完全能够满足板子加工制造

过程中的各种需求 CAM350 系列软件提供了全面 广泛的解决方案 解决你在整个 CAM 阶段

的各种问题 它能够   

z 准确有效地准备和处理设计数据  

z 在实际加工制造前 全面彻底地分析和修复在设计处理的有关制造过程中可能出现的问题  

z 有效地得到测试数据 铣边框数据和钻孔数据 以及完成拼板过程  

z 减少钻孔磨损 优化路径 删除冗余的金属碎片  

z 自动地完成从加工准备到板子加工出来全过程 

 

CAM350 系列软件的自动化能力能够通过加速你的数据输入时间 减少数据处理时间 提

高效率 增强你的竞争能力 强大的编辑功能 - 例如自动的 draw-to-flash

vector-to-raster 多边形转换 丝印切割(silkscreen clipping) 孤立焊盘(isolated pad)

删除等 - 都能够帮助你检查设计数据 减少数据文件尺寸 使它更加易于管理 彻底地优化

和增强你的整个处理流程 CAM350 系列软件支持多种数据格式 能够优化数据 以满足你的

需要 它能够保证数据的完整性 以便你能够更加快捷有效的工作  

 

CAM350 for Engineering: 非常容易地检测并改正 PCB 制造过程中可以出现的错误 许

多电子设备的生产制造企业现在已经认识到了 在 PCB 制造过程出现的问题 会影响产品的

整个周期 使得需要进行设计的反复 提高的开销 所以需要修改设计 在设计的集成化和

设计思想之间进行折衷处理  

    CAM350 的可制造性分析工具(Design for Fabrication (DFF))分析在 PCB 设计定义的有

关制造规则 使 PCB 设计人员更加容易理解 DFF Analysis 验证 PCB 数据库 直到在制造工

程中会出现的问题都得以解决  

功能特点  

z 直接地读取你的设计数据 并进行所见即所得(WYSIWYG)的显示  

z 分析 标识和自动地修复在你的设计中出现的有关制造的问题  

z 检查腐蚀 丝印 热焊盘和安全间距的冲突  

z 采用拼板功能优化板子的生产加工  

z 建立数控钻控数据和铣切数据  

z 消除在设计过程中可能出现的反复  

z 提高效率 节约时间和金钱 

CAM350 帮助改正制造中可能产生的错误 便于生成加工 减少设计反复 保持设计的完整性  

 

CAM350 for Fabrication: 速度更快 体积更小和更便宜的电子产品使得 PCB 制造加工

过程的压力非常的大 为了缩短加工周期 那些可制造的设计分析是不允许在制造过程中再

来进行的 既要快捷 又要降低成本 提高产量  PCB 制造人员必须确保加工制造数据的正

确性  PCB 的腐蚀  NC 钻孔和铣的操作 以及裸板的测试 都必须是有条不紊地有效工作

保证加工制造周期 以满足 PCB 品质和性能的需要  

    CAM350 的智能化数据结构允许制造和销售工程师能够尽快地评估用户的设计 针对任务
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下订单 以及有关价格和交货期的响应 制造工程师能够使用 CAM350 产生智能化的拼板数

据 优化加工制造过程  NC Editor 允许对设计和面板进行自动化的操作 分析和优化钻孔

/铣的路径  CAM350 提供了建立针床测试和飞针测试所需要的数据 进行 PCB 的加工测试

以保证能够得到高品质的 PCB 产品  

     功能特点  

z 自动地进行 draw-to-flash 转换  

z Vector-to-raster 多边形转换  

z 平面合成 删除转换后的数据  

z 功能强大的制造规则检查 (MRC)  

z PCB 代理报价  

z 灵活和智能化的 Panel Editor  

z 强大的 NC 编辑  

z 飞针测试和针床测试数据处理工具 

    CAM350 支持板厂的整个制造过程 确保用户得到高品质的 PCB 产品和有效的投资  

  

 

 

 

 

 

 

 

 

 

 

 

 

第第三三章章 CCAAMM335500  rreevv77..00 工工具具使使用用  

总体来讲 CAM350 提供了 6 种独立的编辑器 CAM, CAP (Custom Aperture), Part, NC, 

Flying Probe & Bed of Nails  

CAM 编辑器: 这是默认的编辑器 也是最主要的编辑工具 可以用来导入和输出数据

还包括 DRC 拼版及其他制造预备步骤  

CAP(用户 Aperture)编辑器:  

3.1  用户界面介绍 

以下具体介绍基于 CAM350 7.0 版本的工具的各项命令和操作方法 首先介绍并熟悉

CAM350 的用户界面: 
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    上图是 CAM350 的主要操作界面 主要由标题栏 主菜单 工具条 层控制条 状态

栏和工作区域几部分组成 他其实是个CAM编辑器 而其它5个编辑器的功能被放在了 Tools

菜单下 有时为了获得更大的工作区域 可以将 Tool Bar Layer Bar Status Bar 关闭

当然前提是你已能熟练的运用各种快捷键 空格键相当于鼠标左键 逗号相当于鼠标中键

Esc 则相当于鼠标右键  

 

以下具体介绍各个部分的功能和作用  

Main Menu Bar: 在标题的下方 整个窗口的上方的位置是主菜单栏 直接单击鼠标左键

即可打开各菜单 也可通过 ALT 与菜单项首字母的组合打开菜单 如 ALT+F 可打开 File 菜单

项 每项菜单所包含的命令的操作及功能将在后面详细介绍  

Tool Bar: 在主菜单的下方就是工具条 这个动态的工具条包含好几项功能 栅格选择

框是固定的 而其他的如 Active Dcode Active Layer 可以根据具体的命令而改变  

Grid Selection: 这是一个组合框 既可以从下拉列表中选择栅格大小 也可以直接输

入栅格尺寸 输入的 X Y 坐标值可以是整数也可是小数 而且可以是不同的值 如果输入了

X 坐标然后打回车 那么 Y 坐标就默认为与 X 坐标相同  

Active Dcode: 这是一个当前定义的光圈(Aperture)的下拉列表 在列表中被选种的选
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项将被设置为当前击活的 D 码 与热键 D 具有相同功能  

Active Layer: 这个下拉列表包含板子的所有层 单击任何一层将击活该层 并使该成

为当前层 与热键 L 具有相同功能  

Layer Control Bar: 这个垂直的工具条位于窗口的左侧 用来控制所有层的信息 控制

条的上方为 Redraw Add Lyr All On All Off 按钮 其中 Redraw 是刷新显示 与热键

R 有相同功能 Add Lyr 可以在现有的层后面再加一层 同样也可以利用菜单中

Edit->Layers->Add layers 命令实现增加层的操作 All On 按钮将所有层都在主工作区域内

显示出来 All Off 将除当前层之外的所有层都关闭  

鼠标左键点击任意层的数字就可以将该层设置为当前被激活的层 并且会在该层的数字

上显示一个红色的小框 如果右键点击任意层的数字 那么这一层将成为最前面一层 并且

在这层的数字上会有一个蓝色的小框显示  

在代表层的数字右侧是层的颜色 这个颜色分两个部分 左上角的那个三角形是 draw 颜

色 右下脚的三角形是 flash 的颜色 左键点击任意一个区域可以显示和关闭 draw/flash 的

颜色 右击两个三角形可以改变 draw/flash 的颜色 这时就会打开调色板  

 

 

也可以在调色板上选择 Show/Hide 来显示或隐藏 Draw 和 Flash 还可以点击 Load 来导入

另一个调色板  

Status Bar: 在屏幕的最下方是状态栏 提供了有关当前命令 光标所在位置的坐标等

信息 此外 还有 Z S V T H 按钮开关  

显示当前光标位置或设置光标位置 模式: 这个按钮显示了光标所在位置的坐标 并且

精确到小数点后四位 按钮的右边是单位显示 这个单位与 Settings/Units 中的设置是一

致的 此按钮也可以用来直接输入新的坐标 这其实相当于用鼠标左键在工作区内点击所显

示的坐标 要想输入坐标时 只须按一下此按钮 就会有一个对话框显示  

 
此时 对话框中显示的为鼠标左键上次点击的坐标值 可以输入新的坐标 利用回车键切换

X Y 坐标的输入 另外 对话框中还有三种模式可供选择 Absolute/Relative/AutoPan  

Absolute 是绝对坐标模式 这种模式下显示的是实际的坐标值  
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Relative模式是相对坐标模式 这种模式下显示的是当前坐标相对于前一坐标的变化值

此时 屏幕上会出现一个小的圈记录光标前一次所在的位置 在输入坐标时 如果以@符号开

头 系统将默认选择进入 Relative 模式  

如果选择 AutoPan 的话 系统自动显示输入点 包括不在当前显示范围内的点  

命令提示行: 这里显示系统下一个要执行的命令  

Z Button: 此按钮将光标锁定为按对象捕捉模式 也就相当于一个开关 打开时 按钮

就陷进去 并且光标将会变成一个 十 字加一个小框用来捕捉物体 再按一下就关闭该模

式 十 字外面的小框消失 这种模式在网格不显示状态下很方便 另外 这种模式还可

以用热键 Z 控制  

S Button: 此按钮将光标锁定为按网格捕捉模式 也相当与一个开关 打开时 按钮就

陷进去 并且光标将锁定在最近的格点上 另外 这种模式还可以用热键 S 加以控制  

V Button: 此按钮是控制栅格显示/不显示的 当按钮陷下去时表示栅格是显示的 但全

图缩小到一定程度栅格也会小的看不见 反之 栅格将不显示 栅格显示和栅格捕捉这两个

按钮是相互独立的 互不影响 另外 此按钮还可以用热键 V 控制  

T Button: 按下此按钮将进入 透明 模式 在这种模式下 物体在不同层上如果有相

互重叠现象时 交叠的部分将是特殊的颜色 这个颜色是各层的颜色的合成 这样所有层上

的物体都可以看的见 当按钮关闭时 当前激活的层将覆盖其他的层 另外 这个功能还可

以通过热键 T 来控制  

H Button: 打开此按钮 所有当前激活的 D 码都会呈高亮状态 热键 H 也可以实现这

一功能  

DFF 控制板块: 只有购买了 DFF 检验功能块才会有这项控制板块 这个控制板是一个独

立的实体 可以与其他的 CAM 编辑器中的命令同时使用  

Work Space: 这个区域显示了用户的所有图像数据 除了显示相关数据之外 这里还包

括许多工具 可以在在编辑过程中进行控制 具体如下  

• 原点标志(Origin Marker):   

这是表示坐标原点(0,0)位置的固定标志    

• 光标形状(Cursor Shape):   

为表示各种不同的用途 系统设置了几种光标形状 默认的形式是一个简单的 十 字

指向一个 X Y 坐标点 光标的末端还可以延伸至整个屏幕 只要利用热键 X 进行切

换 就可以将光标设置为默认的小 十 字光标 延伸的 十 字光标和延伸的 X
字光标  

 是按下状态条上的 Z 按钮或热键 Z 之后光标所呈现的形状 十 字外的框

确定了一个搜索窗口 并且可以通过 PageUp PageDown 键进行放大和缩小 从而获得

理想的搜索窗口大小  

• 光标移动(Cursor Movement):  

  光标的位置大多数情况下是有鼠标控制的 同样键盘上的上下左右箭头也可以控制屏

幕上光标按照一个象素或格点来移动 水平移动由左右箭头键控制 而垂直方向的移

动则由上下箭头键控制  

• 循环选择(Cycle Picking): 
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  在任意一个功能选择模式下如 Move 或 Copy 可以重复选择编辑对象 这样在执行具体

命令前可以选择多个对象 然后所有被选种的对象将作为一个整体在一个框内 然后

一起进行编辑  

• 几种选择方式(Making Selections): 

在使用一个编辑命令时 如 Move 可以选择单个对象 也可以同时选择多个对象 单

击鼠标左键即可选择单个对象 此时被选种的对象立刻跟随光标移动 并且命令提示

行显示 [Move:Single] 选择多个对象时 只要再同时按下 Ctrl 键 此时的命令

提示行则显示 [Move:Multiple] ,选择完毕后所有被选种的对象被高亮 光标则变

成一个包含所有被选种对象的框 如果想去掉框中的任意对象只要按住 Ctrl 的同时再

点击该对象即可 确定好要移动的对象后就可以移动光标到理想的位置 想快速的选

种一组对象只要按下热键 W 此时 命令提示行显示 [Move:Window] 光标像

一个窗口 点击两个对角线的点确定矩形窗口大小 窗口中的对象都被选种呈高亮状

如果想再选其他矩形窗口 只须按下热键 C 单击鼠标右键结束选择 单击鼠标光

标则变成包含所有组对象的矩形大框 接着可以移动到理想位置  

• 取消命令(Abort Commands): 

在一个命令执行过程中可以通过单击鼠标右键或按下热键 Esc 终止命

令  

 

 

3.2  CAM350 热键及其功能 

热键 实现的功能 

A 打开 Aperture 列表 光圈表  

C 以光标所在点为中心放大鼠标邻近范围 

D 设置当前激活的 D 码 

F 切换显示填充模式 (实填充/外形线/中心线) 

G 图形开关 快速选择编辑  

H 将当前 D 码高亮显示 

K 删除一个或多个层 (当前被激活的层除外) 

L 指定当前层 

M 切换命令行显示方式(记忆模式/命令提示/宏命令提示) 

N 切换当前被激活的层的正片/负片显示 

O 改变走线模式 0/45/90 度  

P 显示图形上一次缩放大小 

Q 查询图形元素的相关数据 

R 刷新屏幕 

S 按栅格移动光标开关 

T 透视显示开关 

U 撤消/恢复 

Ctrl U 重复上次操作 
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V 栅格显示开关 

W 窗口式缩放 必须选取两点  

X 切换光标形状 (短 十 字型/长 十 字型/ X 字型) 

Y 打开层设置对话框 

Z 目标选取开关 以光标为中心  

F1 CAM350 帮助 

F2-F9,F11,F12 用户定义的热键 

Home 全局显示 

0-9 在设置当前层命令下 数字键 1~9 分别代表 Layer 1~Layer 9,而数字键 0

代表 Layer 10  

Ins 按光标在面板中的位置显示图形 

+/- 放大/缩小图形 

PageUp/ 

PageDn 

放大目标选取框/缩小目标选取框 以光标为中心  

 

 

在编辑命令下使用的功能热键  

热键 实现的功能 

A 选中全部图形元素 

B 显示包含所有被选种对象的框/直接显示所有被选种的对象 

C 框选模式 交叉不交叉 

I 窗口选择模式下 窗口内部为被选种/窗口外部被选种 

M 在增加器件 Quick Part 命令下为镜像器件  

在 Build Part Part Edit 命令下为镜像器件的 Reference 

Designator or Device Name 

T 在增加器件 Quick Part 命令下为旋转器件  

在 Build Part Part Edit 命令下为旋转器件的 Reference 

Designator or Device Name 

W 进入组窗口选择模式 

 

键盘和鼠标的相同功能  

键盘 鼠标 

空格键 鼠标左键 

, 鼠标中键 执行上一命令  

Esc 鼠标右键 (结束当前命令) 

 

 

 12 



3.3  各项主要功能实现 

   由于 CAM350 功能非常强大 既支持 PCB 设计者 又支持 PCB 制造者 而我们对 CAM350 的

了解主要是从设计者的角度出发的 因此研究深度不会很远 以下主要从检验 Gerber 数据的

正确性的角度介绍 CAM350 中 CAM Editor 中的一些主要功能如导入 Gerber 文件 层的编辑

改变有关设置 DFM 检验 编辑对象等  

3.3.1 导入 Gerber 文件 

CAM350 中 Gerber 文件的导入有自动导入和手动导入两种方式 手工导入方式比较麻烦

主要用在不能自动识别 D 码时使用 一般很少采用 自动导入方式非常方便 这种方式能自

动识别 D 码 下面分别介绍这两种方法  

1  自动导入 Gerber 文件 

    在导入之前首先确定 Gerber 文件的格式 标准的 Gerber 文件分 RS-274 和 RS-274-X 两

种格式 其不同在于 如果是 RS-274 格式的 Gerber 则必须在文件夹中包含一个独立的

Aperture 文件 如果是 RS-274-X 格式的 Gerber 则无须 Aperture 文件 D码是整和在 Gerber

文件中的 因此不需要 Aperture 文件  

导入时在菜单中选择 File->Import->AutoImport,如图  

 

 
 

接着会弹出一个对话框如图 在此选择 Gerber 文件所在的目录 注意 最好将所有的

Gerber 文件放在同一个独立的文件夹中 这样方便数据的读入  
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然后选择单位 即 English(英制)和 Metric(公制) 选择 English(英制) 因为一般

的 Gerber file 都是英制的 因为大多数 CAD 软体为西方国家的产品 通常系统默认的单位

也是 English(英制) 接着点击 Next 进入一个如图所示的对话框 该对话框罗列了文件夹中

所有的文件文件名 类型(Type) 格式(Format) 还提供是否导入(Import)的选择  

 
 

  值得指出的是 只有在 Format 中正确设置各项参数才能正确的导入 Gerber 数据 点击

任意一个文件的 Format 就会弹出下图所示的 Gerber Format 对话框  
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单位一定要选择 English(英制) 对于*.art 文件 可以选择 Apply to All 将设置

延伸到其他 gerber 文件 对于 Aperture 文件的类型 如果是 RS-274-D 要选择 Aperture

如果是 RS-274-X 则选择 RS-274-X no Aperture ,其格式根据不同的 EDA 软件有 ALLEGRO

CADSTAR MENTOR ORCAD PADS VERIBEST ZUKEN 等许多种选择 而每一种软件由于版本

的高低又提供多种选择 最后 点击 Finish 就可以成功导入 Gerber 数据  

 

 

2  手动导入 Gerber 文件 

    手动导入时选择菜单项 File->Import->Gerber Data 出现下图左边的对话框  

 

在左图中先通过 Data Format 按钮设置相关数据 如单位 RS-274-D/RS-274-X 精

确度等 如果是 RS-274-X 格式则可直接导入各层 但是 RS-274-D 格式的 Gerber 还要设置

Aperture 文件 点击 OK 后就变成右边的对话框可以设置 Aperture 文件 点击 Aperture 
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File 按钮则弹出一个 Aperture 对话框  

 

和自动导入时一样 选择 Others 然后根据不同的 EDA 软件选择 Aperture 的格式 然后由

Aperture File 找到该文件的目录 OK 以后即可导入各层数据  

 

3.3.2 层的编辑 

CAM350 中对层的编辑功能基本包括增加/删除层 更改各层顺序 设置层的状态和参数

层的组合等  

 

1  增加 /删除层 : 增加层有两种方法 直接利用热键 L 或者利用菜单项     

Edit->Layers->Add Layers,会出现 Add Layers 的对话框 直接在 Number of new 

layers 后输入需要增加的层数 删除层的方法同样有两种 直接按下热键 K 或者

利用菜单项 Edit->Layers->Remove Layers 会出现 Kill  Layers 对话框 直接

输入被删除的层的序列号即可删除该层 需要删除多个层时 用逗号隔开  

2  更改各层顺序: 有时为了看起来方便想按一定顺序排列各层 这可以通过菜单项

Edit->Layers->Reorder Layers来实现更改各层的顺序的功能 出现下图左边的对话框

 

  调整顺序时先选种要调节顺序的层 然后移动鼠标到理想的插入点即可 最后按下          
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Renumber 排序 右图为调整过的各层顺序  

3  设置层的状态和参数: 查看 更改各层信息可以按下热键 Y 或利用菜单项    

Tables->Layer Table 层信息包括层的名字 层的类型 Flash/Draw 颜色 层的状态

(On/Off/Ref) 是否是当前被激活的层 是否在最前面一层  

4  层的组合: 在看 Gerber 时经常会需要同时打开某几层一起看 这时 利用某个热键一

下子打开几层就会显的非常便捷 CAM350 中的 层组合设置功能 就能很好的做到有目

的将几层并为一组并简单的使用一个热键就能同时打开这组内所有的层 在 CAM350 中

有四种不同的层组合选择分别为 User/Layer Stackup/Blind and Buried/MCM 

Technology 其中 User 为通用的用户定义类型 Layer Stackup 是在拼版过程中使用

的层组合设置 Blind and Buried 是配合 Netlist 的产生使用的 MCM Technology 是

专门针对 MCM 技术的基板的 Gerber 文件 这四种形式下的层组合设置功能可以通过

Table->Layer Sets-> 菜 单 下 的 四 个 选 择 来 实 现 如 下 图 所 示 位 置  

  

    由于 Layer Stackup/MCM Technology 和我们内存 PCB 设计关系不大 这里仅介绍 User

和 Blind and Buried 两种方式 关于打开组合层的热键  CAM350 是这样规定的 系统默认

的热键为数字键 0~9 从 1 开始为第一个层组合设置 依次类推 0则代表第 10 个层组合设

置 当然 CAM350 可以设置 10 个以上的层组合 但只有前 10 个可以通过热键打开  

z 首先介绍 User 类型 打开 Tables->Layer Sets->User 菜单会出现如下图中左边的

User Layer Sets 对话框  
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  在左边的 Layer Sets 列表中是层设置的名称及其分配的热键数字 名称是在右边的

name 框中输入的 名字可以使用默认的 LyrSet_1 也可以根据自己的要求使用诸如

Top_View 之类的带有一定说明性 但是命名中不允许包含空格 一般在 Layer Sets

列表中显示的是 LS1: LyrSet_1<⋅⋅ Hot Key 1 ,但如果在其他三种类型 Layer Stackup/Blind 

and Buried/MCM Technology 中已有过设置 则将自动以下一个未使用的热键开始 如图中

是以 LS1: LyrSet_1<⋅⋅ Hot Key 1 开始的 则表明热键 1 已经使用过 接下依次来点击右

边的数字按钮来加入每个 Layer Sets 中包含的层 如点击 1 按钮就会弹出如上图右边的

Layer List 的选择框 OK 后该层就显示在 1 按钮右侧的框中 点击 2 按钮加入另一层

重复这个过程直到所有的期望的层都被加入 如果还要在编辑一个层组合只要点击 Add 按钮

然后重复刚才的操作即可 当然 点击某个 Layer Sets 按下 Delete 就可以删除该设置 也

可以选择组内的各层 所有这些设置将被保存在*.CAM 文件中以备下子使用  

z  接着介绍 Blind and Buried 类型 这个功能只有当 Gerber 文件中含有盲孔 埋孔信

息时才有效 由于这个功能是配合 Netlist 的提取而设置的 必须在提取 Netlist 之前先设

置层 只有先告诉系统 Blind and Buried 在哪个层组合 才能提取正确的 Netlist 具体实

现过程与 User 类型相类似 打开 Tables->Layer Sets->Blind and Buried 菜单项 出现下

图所示的 Layer Sets For Blind and Buried Via 对话框  
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 Layer Sets 的命名及层的加入都和前面讲的一样 只是还要调入两个钻孔文件 点击 Thru 

Drill  按钮并选择通孔钻孔文件 如 ncdrill1.tap 也可以另外命名 再点击 Drill Data

选择相应的文件 当 Blind and Buried 类型的层组合设置成功后 在 Layer Talbe 对

话框下方的 By Layer Set 按钮才会有效  

 

3.3.3 改变有关设置 

和其他软件一样 CAM350 也可以更改有关设置 如改变单位 字体 宏设置等 这里就

简单介绍提到的这三种设置  

1. 单位 利用 Settings->Units 菜单可以改变单位的设置 提供选择的有英制

(English-mils) 公制(Metric mm)两种 此外对每一种单位都提供 5 中由低到高的精确度

选择  

2. 字体 利用 Settings->Text 可以打开 Text Style 对话框 如下左图所示  
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在这个对话框中可以设置不同字体 字高 字间距 对齐方式等参数 点击 Font 按钮即

可打开右图所示的 Font List 字体选择列表 选择理想的字体 在下方的框中会出现相应

的该字体的模板 然后 OK 在选择了字体后 Font 按钮右边的提示就会显示该字体如 Times 

New Roman 从而取代默认的 Simple 字符和线的间距在 Spacing 中设置 垂直/

水平方向的对齐方式在 Justification 中分别进行设置  

 

3. 宏命令设置 Macro 那些能自动执行某种操作的命令统称为 宏 宏也是一种操作

命令 它和菜单操作命令都是一样的 只是它们对数据库施加作用的时间有所不同 作用时

的条件也有所不同 菜单命令一般用在数据库的设计过程中 而宏命令则用在数据库的执行

过程中 菜单命令必须由使用者来施加这个操作 而宏命令则可以在数据库中自动执行

CAM350 中也集成了宏命令极其相关的操作 即可以利用热键开启一个菜单项命令或宏命令也

可以利用 BASIC 语言编写复杂的脚本,这样就利用简单的语法 把常用的动作写成宏 当在工

作时 就可以直接利用事先编好的宏自动运行 去完成某项特定的任务 而不必再重复相同

的动作 由于编写*.scr 文件的宏文件涉及到语言编程问题 这里仅介绍如何利用热键执行

菜单项命令的功能  

对于频繁使用到的菜单项 可以利用这一功能快速的执行 这样就节省了时间 例如

File->New File->Save As Zoom In/Out File->Import->AutoImport 等常用的命令都可

以直接用热键打开  

这一功能的实现是在 Macro->Assign->Function Keys 菜单下 打开有弹出如下左图所示

的 Function Keys Assignment  对话框  
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这是默认打开后的对话框 从图中可看到顶端的下拉框中显示的是 FnKey 而下面

列出了所有 12 个功能热键 F1~F12 其中 不难发现 F1 和 F10 是显灰而不能使用的 因

为这两个已被系统占用 但 CAM350 提供的热键分配远不止这 10 个 在右图中可以看到顶端

的下拉框中还有 Shift+FnKey/Ctrl+FnKey  可供选择 而 F1~F12 对于这两种组合热键都

是有效的 如果把热键和组合热键加在一起 CAM350 能提供 34 种快速打开菜单命令项的选

择  

如何实现热键与菜单项命令的连接呢 在每个热键按钮的右侧有一个按钮 可以选择

Script  与 Menu 两种 在此 选择 Menu 模式 然后再点击热键按钮 会有一个如

图所示的 Pick Manu Item 对话框弹出  

 

例如 利用 Shift+F2  执行 新建 命令的操作如下 首先在下拉框中选择 Shift+FnKey

在 F2 按钮右边的按钮中选择 Menu  然后再点击 F2 按钮打开菜单项选择框并选择

File|New 按 OK 确定 重复这个过程可以继续定义其他菜单项和热键组合 在每个热键

按钮的最右边有一个 DEL 按钮 可以用来删除已设置的菜单项  

 

 

3.3 .4 DFM 检验 

CAM350 的软件自动检测功能对设计者和制造者都是很实用的 这里主要从设计者的角度

介绍 CAM350 中的 DFM 检验的各项功能 这些功能大部分都集中在 Analysis 菜单下 这里将逐
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一介绍其中主要功能的操作方法  

1.  Silk to Solder Spacing 

这是一个软件自动检验丝印层与阻焊层间距的功能 打开菜单项 Analysis->Silk to 

Solder Spacing 就弹出一个如下的 Check Silkscreen 对话框  

 

 在这个对话框中首先选择要检查的两层 即 sildcreen_top/soldermask_top 同时选种或

sildcreen_bottom/soldermask_bottom 同时选种 然后在 Clearance 中输入可以容忍的最小

间距如 3mils 最好在 Remove Old Silkscreen Errors  前打上钩 以免混淆 OK 后系统

执行查找 此时屏幕底端左边显示 Silk to Sold Check 右边显示百分比 执行完毕后

会弹出一个抱错信息框如   

确定 后屏幕跳转至这两层信息 并且屏幕的右上方会增加一个信息显示/编辑条  

 
在这里可以查看所有错误具体位置 可以点击 All 显示所有的错误 也可以下拉框中选种

某一个 error 这样可以查询这个 error 的具体位置  

 

2.  Solder Mask to Trace Spacing 

   在一般的 EDA 软件中定义为 SOLDER MASK 的地方 在实际做板的时候就是涂焊锡的地方

没有 SOLDER MASK 的地方 做板时就是阻焊剂 阻焊剂的主要目的是避免在焊接过程中焊料

无序流动而导致焊盘引线之间 桥接 短路 保证安装质量 提供长时间的电气环境和抗化

学保护 形成印刷电路板漂亮的 外衣 这个命令就是一个实现软件自动检查走线和

Sold(焊料)间距的功能 具体步骤为 打开菜单项 Analysis->Solder Mask to Trace Spacing

就会弹出如图所示的 Check Solder Mask 对话框  

 22 



 
在这个对话框中分别选择要检查的 Electrical Layer 与 Solder Mask Layer 两层 也就

是同时选种 Top/Soldermask_top 层 或者同时选种 Bottom/Soldermask_Bottom 层 然后在

Clearance 中输入可以容忍的最小间距如 2.5mils 最好在 Remove Old Solder Mask Errors  

前打上钩 以免混淆 OK 后系统执行查找 此时屏幕底端左边显示 Solder to Trace Check

右边显示百分比 执行完毕后 如果没发现任何错误则会显示  

 

如果有错就会弹出一个抱错信息框如  

同样的 确定后屏幕会跳转至这两层信息 并且屏幕的右上方会增加一个信息显示/编辑条

 
在这里可以查看所有错误具体位置 可以点击 All 显示所有的错误 也可以下拉框中选种

某一个 error 这样可以查询这个 error 的具体位置  

 

3.  Copper Silvers 

   Copper Silvers 是指那些在生产过程中容易造成脱落的细而窄的铺铜区域 这项功能

不仅能检测出细窄的铺铜区域 而且还有修复/修剪功能 在执行这个操作前首先要打开需要

检测的相关层 打开菜单项 Analysis->Copper Silvers 即可弹出下图所示的 Copper Silver 

Detection 对话框  
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首先在 Find Silvers less than 后输入最小能容忍的铜面积数 mil , 在 Processing 

Control  中可以选上 Fix Silvers 以修复细铜 选择 Remove Old Slivers 即消除

原先产生过的检测结果如 Mask Silvers 而在下面的 Search Area 中如果选择 Process 

Entire Layer 表示系统将对当前打开的所有层进行检测 如果选择 Window Area to 

Process 则表示先选择一个窗口 系统将对窗口所在区域进行检测 OK 后 系统将持续一

段时间的检测 最后弹出一个提示信息 如果没有错误将显示 Found no new Silvers ,

如果发现错误将显示如 确定后屏幕会跳转至另一个编辑窗口

右上方出现一个信息显示/编辑条  

 

 
 

在这里可以查看所有错误具体位置 可以点击 All 显示所有的错误 也可以下拉框中选

种某一个 error 这样可以查询这个 error 的具体位置  

 

4.  Mask Silvers 

   Mask Silvers 是指那些在生产过程中容易造成脱落的阻焊层上 俗称 绿油 的阻焊

剂 细而窄的区域 阻焊剂一旦剥落很容易滑向焊料造成不良后果 这一功能项就可以在生

产之前预先检测并修复一下以免造成不必要的后果 具体操作为 打开菜单项Analysis->Mask 

Silvers, 弹出一个 Mask Silver Detection 的对话框 如图  
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首先在 Find Silvers less than 后输入最小能容忍的铜面积数 mil , 在 Processing 

Control  中可以选上 Fix Silvers 以修复细铜 选择 Remove Old Slivers 即消除原

先产生过的检测结果如 Mask Silvers 而在下面的 Search Area 中如果选择 Process 

Entire Layer 表示系统将对当前打开的所有层进行检测 如果选择 Window Area to Process

则表示先选择一个窗口 系统将对窗口所在区域进行检测 OK 后 系统将持续一段时间的检

测 最后弹出一个提示信息 如果没有错误将显示 Found no new Silvers ,如果发现错误

并且已经修复了错误之处将显示如 确定后屏幕会跳转至

另一个编辑窗口 右上方出现一个信息显示/编辑条  

 

 

在这里可以查看所有错误具体位置 可以点击 All 显示所有的错误 也可以下拉框中选种

某一个 error 这样可以查询这个 error 的具体位置  

 

5.  Find Solder Bridges 

   在大多数的 EDA 软件中设计 PCB 时都会定义一层 Solder Mask 这在生产上就是所谓的阻

焊层 对于焊盘上未定义 Solder Mask 的区域 也就是生产时上焊料 助焊剂的地方 如果

这个区域定义的过大 将会使该焊盘附近的走线或其他导电物体裸露在阻焊剂之外 从而在

加工时该焊盘与其邻近的金属走线容易形成 桥接 造成短路现象 由此可见 生产上的

Solder Bridges 现象通常是由于设计阶段的 mask 数据的不恰当定义并且 CAD 系统又没

有及时发现而引起的 因此 在生产加工之前快速的检测并修复 Solder Bridges 现象是

非常必要的  

 

CAM350 不仅能快速的发现 Solder Bridge 同时还能进行修复 加工前实现前实现这

一功能只要利用菜单 Analysis->Find Solder Bridges 打开如下入所示的 Solder Bridging
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对话框  

 

在 Top Check/Bottom Check 前的小方框中打上钩可以选择只对表层或底层检测或者

同时检测 在后面的 Mask Layer Check Against 中选择正确的层 注意 Soldermask_top

对应 Top 层 Soldermask_bottom 对应 Bottom 层 在 Bridge Distance  中输入最小能忍

受的 桥接 间距 如 3mils 在下面的 Search Area 中如果选择 Process Entire Layer

表示系统将对当前打开的所有层进行检测 如果选择 Window Area to Process 则表示先

选择一个窗口 系统将对窗口所在区域进行检测 OK 后 系统将持续一段时间的检测 最后

弹出一个提示信息 如果没有错误将显示  

,如果发现错误系统弹出

的信息框将提示如 Found 8 solder bridge errors, fixed 0 errors, 8 errors remain.

这样的信息 确定后屏幕会跳转至另一个编辑窗口 右上方出现一个信息显示/编辑条  

 

在这里可以查看所有错误具体位置 可以点击 All 显示所有的错误 也可以下拉框中选种

某一个 error 这样可以查询这个 error 的具体位置  

 

6.  Find Starved Thermals 

    

7.  Check Drill 

这个功能项是用来检验钻孔层的各种问题的 例如孔与孔之间的距离是否合理 是否在

同一位置上有两个大小相同或大小不一的孔 具体步骤是打开 Analysis->Check Drills 菜单

项 弹出如下图所示的对话框  
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在这个对话框中有许多选择 这些选择分别提供了对钻孔的不同方面的检验 如

Overlapped Drill Hits 可以检查在同一位置是否有两个相互重叠的过孔 Coincident 

Drill Hits (Different Sizes) 可以检验在同一位置是否有两个或两个以上的相同尺寸的

过孔 但这些过孔是由不同的 Tools 产生的 Redundant Drill Hits (Same Size) 可以

检查在同一位置是否有两个或两个以上的相同尺寸的过孔 但这些过孔是由相同的 Tool 产生

的 Drill Hole to Drill Hole Clearance 可以检验过孔之间的间距是否满足某种即定

的规则 如 6mils 接着在 Layers to Analyze 中选择需要检验的层  

 

    最后 有两个命令是适用于所有上面介绍的 DFM 检验功能 对于以上介绍的 DFM 检验各

项功能都可以在 Info->Report 菜单中产生一个报告以显示检测结果 如 Silver Report

Solder Mask Errors Report Silkscreen Errors Report 等并可保存为*.rpt 文件  

当然 如果已经运行过这些检验功能 只是想在看看他们具体所在的位置可以通过

Info->Find 菜单来实现 也可以在 Analysis 下的某个菜单项的对话框中直接点击 Control 

Penal 即可  

 

3.3.5 其他各项功能简介 

除了上一节中介绍的各项功能 CAM350 中还有一些基本的编辑功能如 Move  Copy

Delete  Rotate Add Line/text/polygon/rectangle/circle 等 这里简单介绍 Move 和

Add text 两个具有代表性的编辑功能  

Move 在菜单项 Edit->Move 命令下就进入了 Move 的编辑窗口 如图  

 

其中 Drw/Flsh/Drill/Mill  等提供了一个过滤功能 只有选种时才能高亮相应的对象  

选择多个对象可以结合 CTRL 键 或利用热键 W 选择对象完毕后可以 Move 到相同层的不

同位置 也可以 Move 到不同层的相同位置 只需点击 Move To Layer 按钮  
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 Add Text 可以在任意一层上添加文字说明 选种 Add->Text 菜单项 就进入一个如图

所示的编辑栏  

其中 Style 按钮是用来设置文本的字体 大小 对齐方式 字间距的 D 码列表中选择合适

的 D 码 在层列表中选择文本所在的层  

另外 CAM350 还可以导入或到处*.dxf 文件 因为 CAM350 中文件保存后为*.cam 文件

而后缀为 cam 的文件只能用 CAM350 打开 而其他许多软件都能读*.dxf 文件 如果想通过其

他软件 如 AutoCad GC-CAM GerberTool Genesis2000 中打开经 CAM350 处理的文件就

可以通过导出*.cam 文件来实现  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

第第四四章章 CCAAMM335500  使使用用技技巧巧浅浅谈谈  

对任何软件的使用都必然会经历一个从 认识⇒入门⇒熟悉⇒技巧掌握 的过程 软件的

功能是全面而强大的 只有靠不断的摸索和反复的操练才能一步一步的熟悉 只有靠不断的

钻研才能挖掘出一些应用中的技巧 从而在不断的积累过程中进步 以下为目前所掌握的一

些简单的技巧  

1.  在导入 Gerber 文件时(File->Import->AutoImport) 不能直接点击 Finish 键 要首先

进入 Next 这里可以设置每一层的类型 格式 是否导入等 在格式中可以打开一个 Gerber 
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Format 的对话框  这个格式一定要设置好 导入的图形将

会失真或者无法导入 精确度要正确设置 否则在测量过程中会带来很大误差 单位一定选

择英制(Engish) 为了快速省时 可以在 Apply to All 前打上钩 把该设置应用到其他

要导入的层  

2.  导入 Gerber 文件后不管是查看文件是否正确 还是进行 DFM 检查或者制作生产上需要 

的文件 最好先将各个层的类型定义清楚  

3.  充分利用 Layer Set 功能将经常需要同时打开的一些层定义为一组只用一个热键即可方 

便打开  

4. 要执行某个操作前要打开有关层 如要检查 Mask Silver 就必须打开相关的 Soldermask  

层 

5.  有些命令有先后顺序 如 netlist extract 

6.  导入的 Gerber 文件如果进行了如定义层类型 层组合设置等操作 如果不保存为*.cam 

文件 再次打开时所有设置都将不存在 所以 如果想再次打开该 Gerber 文件进行编辑时

最好将文件先保存为*.cam 文件  
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